Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001014 [Squeak] Tools feature N/A 03-24-05 14:30 04-09-09 18:13
Reporter sge View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.8
  Product Build
Summary 0001014: [ENH] TallySupport
Description From: bergel@iam.unibe.ch <bergel@iam.unibe.ch>
Reply-To: The general-purpose Squeak developers list <squeak-dev@lists.squeakfoundation.org>
To: squeak-dev@lists.squeakfoundation.org
Date: Wed, 23 Mar 2005 16:57:14 +0100 (MET)
Subject: [ENH] TallySupport

from preamble:

"Change Set: TallySupport
Date: 23 March 2005
Author: Alexandre Bergel

Provide a better support for message tally.
Add a 'tallyIt' entry in textmorph similar to 'doIt', 'printIt', ... It
also add a new button in the debugger to quickly tally an expression."!
Steps To Reproduce
Additional Information This works after evaluating 'ParagraphEditor initializeTextEditorMenus', i.e., the changeset doesn't automate menu update.

I left it in 'any' since it touches the Compiler, Debugger, and Morphic categories.
Attached Files  TallySupport.cs [^] (9,286 bytes) 03-24-05 14:30

- Relationships

- Notes
(0001297 - 101 - 101 - 101 - 101 - 101 - 101)
KenCausey
03-24-05 19:26

Conceptually it seems primarily related to profiling/debugging and so I moved it to Debugger for now.
 
(0001300 - 115 - 133 - 133 - 352 - 352 - 352)
sge
03-25-05 01:47

I saw this changeset work in 2 different images:

3.8gamma[latest update: 0006548]
3.9alpha[latest update: 0006599]
 
(0010538 - 98 - 110 - 110 - 110 - 110 - 110)
edgardec
04-13-07 20:36

Alexandre:
I slight modify ParagraphEditor >> yellowButtonExpertMenu and do 7087TallySupport.1.cs
 
(0012606 - 48 - 48 - 48 - 48 - 48 - 48)
KenCausey
09-09-08 15:23

Harvested with update 7087 and released in 3.10.
 

- Issue History
Date Modified Username Field Change
03-24-05 14:30 sge New Issue
03-24-05 14:30 sge File Added: TallySupport.cs
03-24-05 19:26 KenCausey Note Added: 0001297
03-24-05 19:26 KenCausey Category Any => Debugger
03-24-05 19:26 KenCausey Description Updated
03-25-05 01:44 sge Note Added: 0001298
03-25-05 01:46 sge Note Added: 0001299
03-25-05 01:47 sge Note Added: 0001300
03-25-05 01:49 sge Note Deleted: 0001298
03-25-05 01:49 sge Note Deleted: 0001299
04-13-07 20:36 edgardec Note Added: 0010538
09-09-08 15:23 KenCausey Status new => closed
09-09-08 15:23 KenCausey Note Added: 0012606
09-09-08 15:23 KenCausey Resolution open => fixed
09-09-08 15:23 KenCausey Fixed in Version  => 3.10
04-09-09 18:13 KenCausey Category Debugger => Tools


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
68 total queries executed.
42 unique queries executed.
Powered by Mantis Bugtracker