Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001383 [tweak] Any minor always 06-28-05 13:16 07-15-05 00:56
Reporter corny View Status public  
Assigned To
Priority normal Resolution no change required Platform
Status resolved   OS
Projection none   OS Version
ETA none Product Build
Summary 0001383: CCheckBox expects value: instead of selected:
Description to initialize a CCheckBox one can either use select or deselect or directly set value: to the designated boolean.

One would also expect, that using selected: will set the value of the CheckBox. This does not happen though.

It is not a bug, but it can lead to misunderstanding, since selected: is implemented in CButton, but not in CCheckBox.

Solution:
CCheckBox selected: aBoolean
  self value: aBoolean
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0001794 - 330 - 340 - 340 - 340 - 340 - 340)
andreas
07-15-05 00:56

This is interpretation is incorrect. The "selected" state is a purely visual indicator for how a button should be drawn. Changing the visual appearance must not change the value of the checkbox, but changing the value of the checkbox should indeed change the visual appearance. This is simply a one-way and not a two-way relation.
 

- Issue History
Date Modified Username Field Change
06-28-05 13:16 corny New Issue
07-15-05 00:56 andreas Status new => resolved
07-15-05 00:56 andreas Resolution open => no change required
07-15-05 00:56 andreas Assigned To  => andreas
07-15-05 00:56 andreas Note Added: 0001794
07-15-05 00:56 andreas Assigned To andreas =>


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker