Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001407 [Squeak] System tweak always 07-02-05 03:05 01-18-06 23:48
Reporter masm View Status public  
Assigned To ohshima
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.8
  Product Build
Summary 0001407: FileStream>isSourceFileSuffix: and senders
Description Timothy Rowledge <tim@sumeru.stanford.edu>:

I notice that isSourceFileSuffix includes '*' as an option and yet
three of the four senders use
(self isSourceFileSuffix: foo) or:[foo = '*'] which seems a little
confused.

Someone that knows what is truly intended here might like to check on
this.

tim
Steps To Reproduce
Additional Information
Attached Files  isSourceFileSuffix-M1407.1.cs.gz [^] (337 bytes) 09-16-05 01:09

- Relationships

- Notes
(0002652 - 150 - 150 - 150 - 150 - 150 - 150)
tim
09-15-05 04:46

This is still ugly in the 3.8 final. My thought is that the check for '*' in the isSourceSuffix method should be dropped since it clearly isn't clean.
 
(0002653 - 151 - 163 - 163 - 163 - 163 - 163)
tim
09-15-05 04:49

Reminder sent to: ohshima

Yoshi, could you take a quick look at this? I think the answer is imple but you must have had a good reason for writing the method as it is now.

tim
 
(0002656 - 359 - 405 - 405 - 405 - 405 - 405)
ohshima
09-15-05 08:01

Ah, I haven't though about the implication if we drop it from isSourceFileSuffix:, but I think it is ok.

  m17n codebase is derived from 3.2 and modified 3.6. For these images, including '*' was simply compatible with the official release.

(cf. hg 8/3/2000 18:13 FileStream class isSourceFileSuffix:)

Just edit it away and see if somebody complains.
 
(0002666 - 91 - 91 - 91 - 91 - 91 - 91)
tim
09-16-05 01:10

OK, the obvious trivial change is in the attached changeset. I couldn't see anything break.
 
(0002734 - 35 - 35 - 35 - 35 - 35 - 35)
MarcusDenker
09-29-05 18:10

changeset needs to be added to 3.9.
 
(0003543 - 15 - 15 - 15 - 15 - 15 - 15)
MarcusDenker
01-18-06 23:48

will be in 6716
 

- Issue History
Date Modified Username Field Change
07-02-05 03:05 masm New Issue
07-02-05 06:10 tim Status new => assigned
07-02-05 06:10 tim Assigned To  => tim
09-15-05 04:46 tim Note Added: 0002652
09-15-05 04:47 tim Assigned To tim => ohshima
09-15-05 04:49 tim Note Added: 0002653
09-15-05 08:01 ohshima Note Added: 0002656
09-16-05 01:09 tim File Added: isSourceFileSuffix-M1407.1.cs.gz
09-16-05 01:10 tim Note Added: 0002666
09-29-05 18:10 MarcusDenker Status assigned => resolved
09-29-05 18:10 MarcusDenker Resolution open => fixed
09-29-05 18:10 MarcusDenker Note Added: 0002734
01-18-06 23:48 MarcusDenker Status resolved => closed
01-18-06 23:48 MarcusDenker Note Added: 0003543
01-18-06 23:48 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
63 total queries executed.
43 unique queries executed.
Powered by Mantis Bugtracker