Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001493 [Squeak] Graphics minor always 07-19-05 18:49 07-22-05 22:22
Reporter ducasse View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version
  Product Build
Summary 0001493: [BUG] in color (Color r: 1 g:0 b:0) * #(1 1 1) -> DNU
Description in the comment of Color we read that we can * a color by an array to get

    self assert: (Color r: 1 g:0 b:0) * #(1 1 1) = Color red

But (Color r: 1 g:0 b:0) * #(1 1 1) raises an error
Steps To Reproduce
Additional Information
Attached Files  ColorTimeArray-fbs.cs.gz [^] (747 bytes) 07-19-05 18:54

- Relationships

- Notes
(0001842 - 450 - 608 - 655 - 655 - 655 - 655)
KenCausey
07-19-05 18:50

"Frank Shearar" <Frank.Shearar@rnid.org.uk>:

"Hm yes; Color>>* has a method pattern (I can't recall the proper name?) of

* aNumber
    "Answer this color with its RGB multiplied by the given number. "
    "(Color brown * 2) display"

and dates from 1997/02/11 - it looks like the comment is just plain wrong?

I don't mind writing a fix, if someone tells me which solution to use: fix the comment, or fix the code (and of course write a test)."
 
(0001843 - 124 - 178 - 225 - 225 - 225 - 225)
KenCausey
07-19-05 18:53

"Frank Shearar" <Frank.Shearar@rnid.org.uk>:

"Why work when I can procrastinate & work on Squeak?"

Changeset attached.
 
(0001903 - 34 - 34 - 34 - 34 - 34 - 34)
MarcusDenker
07-22-05 22:21

tested the fix: Solves the problem
 
(0001904 - 7 - 7 - 7 - 7 - 7 - 7)
MarcusDenker
07-22-05 22:21

in 3.9a
 

- Issue History
Date Modified Username Field Change
07-19-05 18:49 KenCausey New Issue
07-19-05 18:49 KenCausey Reporter KenCausey => ducasse
07-19-05 18:50 KenCausey Note Added: 0001842
07-19-05 18:53 KenCausey Note Added: 0001843
07-19-05 18:54 KenCausey File Added: ColorTimeArray-fbs.cs.gz
07-22-05 22:21 MarcusDenker Status new => resolved
07-22-05 22:21 MarcusDenker Resolution open => fixed
07-22-05 22:21 MarcusDenker Assigned To  => MarcusDenker
07-22-05 22:21 MarcusDenker Note Added: 0001903
07-22-05 22:21 MarcusDenker Assigned To MarcusDenker =>
07-22-05 22:21 MarcusDenker Status resolved => closed
07-22-05 22:21 MarcusDenker Note Added: 0001904
07-22-05 22:22 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
54 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker