Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001807 [Squeak] MVC major always 09-21-05 22:39 01-20-06 23:37
Reporter BGaertner View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0001807: Error notifier does not open in an MVC project
Description This is for Squeak 3.9 0006686.
The error notifier does not come up in a MVC project.
To reproduce the problem, do this:
1. Enter an MVC project, open a Workspace
2. Evaluate (-4)sqrt. This statement throws an exception.
3. Nothing happens until you switch back into a Morphic project. As soon as you are in the Morphic project, you will the the error notifier and can open the debugger.
Steps To Reproduce
Additional Information I think the problem is in the method
Debugger class>>openOn:context:label:contents:fullView.

There is a version with label ajh 8/6/2003 and that version works.
The newer version with label md 8/9/2005 does not work. I think that the
Message
WorldState addDeferredUIMessage:

is unsuitable for MVC.
Attached you find a proposal for a fix, but I am really do not know whether this is really a fix or only a hack that might create problems elsewhere. Comments are highly welcome.
Attached Files  MVC-DebuggerFix.1.cs [^] (2,234 bytes) 09-21-05 22:40

- Relationships

- Notes
(0003583 - 17 - 17 - 17 - 17 - 17 - 17)
MarcusDenker
01-20-06 23:37

fixed in 3.9a6717
 

- Issue History
Date Modified Username Field Change
09-21-05 22:39 BGaertner New Issue
09-21-05 22:40 BGaertner File Added: MVC-DebuggerFix.1.cs
10-25-05 20:54 BGaertner Issue Monitored: BGaertner
01-20-06 23:37 MarcusDenker Status new => closed
01-20-06 23:37 MarcusDenker Note Added: 0003583
01-20-06 23:37 MarcusDenker Resolution open => fixed
01-20-06 23:37 MarcusDenker Fixed in Version  => 3.9
03-22-09 16:55 shelob Issue Monitored: shelob


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
43 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker