Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001837 [Squeak] System trivial always 10-04-05 14:23 12-19-05 15:53
Reporter pmm View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.7
  Product Build
Summary 0001837: #printShowingDecimalPlaces: doesn't work for moderate or big numbers
Description Decription:
Number>>#printShowingDecimalPlaces: doesn't work for moderate or big numbers

Setps to reproduce:
12000000 printShowingDecimalPlaces: 2

observed behavior:
'1.2e'

expected behavior:
'12000000.00'
Steps To Reproduce
Additional Information See attached fileOut for possible fix.
Attached Files  Number-printShowingDecimalPlaces.st [^] (1,355 bytes) 10-04-05 14:23
 Number-printShowingDecimalPlaces-avi.st [^] (1,280 bytes) 11-14-05 09:03

- Relationships
related to 0000150closed  Number>>printShowingDecimalPlaces: output incorrect 

- Notes
(0003076 - 67 - 73 - 73 - 73 - 73 - 73)
pmm
11-14-05 09:04

I attached the version Avi uses for dabble.
It's superior to mine.
 
(0003241 - 66 - 78 - 202 - 202 - 202 - 202)
pmm
12-09-05 11:50

duplicate of:
http://bugs.impara.de/view.php?id=150 [^]
please close
 
(0003357 - 16 - 16 - 16 - 16 - 16 - 16)
ducasse
12-19-05 15:53

duplicate of 150
 

- Issue History
Date Modified Username Field Change
10-04-05 14:23 pmm New Issue
10-04-05 14:23 pmm File Added: Number-printShowingDecimalPlaces.st
11-14-05 09:03 pmm File Added: Number-printShowingDecimalPlaces-avi.st
11-14-05 09:04 pmm Note Added: 0003076
12-09-05 11:50 pmm Note Added: 0003241
12-19-05 15:52 ducasse Relationship added related to 0000150
12-19-05 15:53 ducasse Status new => closed
12-19-05 15:53 ducasse Note Added: 0003357
12-19-05 15:53 ducasse Resolution open => fixed
12-19-05 15:53 ducasse Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
52 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker