Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0001949 [Squeak] Network minor always 10-12-05 10:36 01-14-06 11:40
Reporter pmm View Status public  
Assigned To gokr
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.8 Product Version 3.7
  Product Build
Summary 0001949: unneccssary #initialize in UUID class >> #new
Description new in UUID is implemented as followed:
new
    ^(self new: 16) initialize


the #initialize is unneccesary because it's already sent but it makes UUID creation almost twice as expensive as needed
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0003261 - 20 - 20 - 20 - 20 - 20 - 20)
pmm
12-10-05 10:50

this is fixed in 3.8
 
(0003267 - 9 - 9 - 9 - 9 - 9 - 9)
gokr
12-10-05 20:53

Will fix.
 
(0003325 - 27 - 27 - 27 - 27 - 27 - 27)
gokr
12-14-05 23:31

This has been fixed in 3.8.
 
(0003487 - 5 - 5 - 5 - 5 - 5 - 5)
MarcusDenker
01-14-06 11:40

fixed
 

- Issue History
Date Modified Username Field Change
10-12-05 10:36 pmm New Issue
12-10-05 10:50 pmm Note Added: 0003261
12-10-05 20:52 gokr Status new => assigned
12-10-05 20:52 gokr Assigned To  => gokr
12-10-05 20:53 gokr Note Added: 0003267
12-10-05 20:53 gokr Status assigned => confirmed
12-14-05 23:31 gokr Status confirmed => resolved
12-14-05 23:31 gokr Fixed in Version  => 3.8
12-14-05 23:31 gokr Resolution open => fixed
12-14-05 23:31 gokr Note Added: 0003325
01-14-06 11:40 MarcusDenker Status resolved => closed
01-14-06 11:40 MarcusDenker Note Added: 0003487


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
52 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker