Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002117 [Squeak] System minor always 10-24-05 15:47 12-19-05 16:57
Reporter sumi View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0002117: Date >> #addMonths: broken
Description Date today addMonths: 1 " => MessageNotUnderstood: Month>>\\ "

It seems that we have to use #monthIndex instead of #month in order to work the method correctly.
Steps To Reproduce
Additional Information
Attached Files  Date-addMonths.st.gz [^] (244 bytes) 10-24-05 15:48
 DateTest-testAddMonths.st [^] (480 bytes) 12-11-05 16:57

- Relationships

- Notes
(0002957 - 32 - 38 - 38 - 38 - 38 - 38)
pmm
10-24-05 18:43

Why no use
Date today + 1 month
 
(0002965 - 94 - 106 - 106 - 106 - 106 - 106)
sumi
10-25-05 07:53

I cannot find Integer >> #month in my image (Squeak3.9a-6693.image).
Where does it come from?
 
(0002977 - 93 - 99 - 99 - 99 - 99 - 99)
pmm
10-25-05 19:26

Sorry, you're right.
I thought because there's #day, #hour, ... there whould be a month too.
 
(0003280 - 12 - 12 - 12 - 12 - 12 - 12)
pmm
12-11-05 16:49

added a test
 
(0003315 - 227 - 245 - 245 - 245 - 245 - 245)
FrankShearar
12-13-05 10:30

Date>>month returns a Month, not a number, so the above description is accurate.

Running 3.9a-6705 the fix and test work perfectly. I think the only thing I'd like to see is the description above replicated in the changeset.
 
(0003358 - 7 - 7 - 7 - 7 - 7 - 7)
ducasse
12-19-05 16:57

in 6707
 

- Issue History
Date Modified Username Field Change
10-24-05 15:47 sumi New Issue
10-24-05 15:48 sumi File Added: Date-addMonths.st.gz
10-24-05 18:43 pmm Note Added: 0002957
10-25-05 07:53 sumi Note Added: 0002965
10-25-05 19:26 pmm Note Added: 0002977
12-10-05 12:30 pmm Issue Monitored: pmm
12-11-05 16:49 pmm Note Added: 0003280
12-11-05 16:57 pmm File Added: DateTest-testAddMonths.st
12-13-05 10:30 FrankShearar Note Added: 0003315
12-19-05 16:57 ducasse Status new => closed
12-19-05 16:57 ducasse Note Added: 0003358
12-19-05 16:57 ducasse Resolution open => fixed
12-19-05 16:57 ducasse Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
63 total queries executed.
42 unique queries executed.
Powered by Mantis Bugtracker