Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002246 [Squeak] Compiler minor always 11-20-05 21:30 01-27-06 09:24
Reporter renggli View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.8
  Product Build
Summary 0002246: Evaluating code and #DoIt/#DoItIn:
Description Evaluating code might leave a method #DoIt/#DoItIn: within the receiver class, this is not annoying for all the tools that check the presence of such a method but might also confuse beginners that don't know where this method is coming from.

Since the possibility to execute compiled methods within a receiver without actually adding them is possible in Squeak, the attached change-set makes use of the feature. This does not create a method called #DoIt/#DoItIn: and is about twice as fast as the old approach.
Steps To Reproduce
Additional Information See the thread in the mailing-list: "What is this DoItIn: method on my class?"

For a next step we should work trough all the tools in Squeak to remove all the unnecessary checks for #DoIt/#DoItIn:
Attached Files  Compiler-evaluateintonotifyingifFaillogged.st [^] (1,470 bytes) 11-20-05 21:30

- Relationships
has duplicate 0002247closed KenCausey Evaluating code and #DoIt/#DoItIn: 

- Notes
(0003637 - 60 - 60 - 60 - 60 - 60 - 60)
MarcusDenker
01-27-06 09:24

This is in 3.9, for some time already (since Traits change?)
 

- Issue History
Date Modified Username Field Change
11-20-05 21:30 renggli New Issue
11-20-05 21:30 renggli Status new => assigned
11-20-05 21:30 renggli Assigned To  => KenCausey
11-20-05 21:30 renggli File Added: Compiler-evaluateintonotifyingifFaillogged.st
11-20-05 21:34 renggli Issue Monitored: renggli
11-21-05 18:54 KenCausey Assigned To KenCausey =>
11-21-05 18:54 KenCausey Status assigned => new
11-21-05 18:54 KenCausey Category Any => Compiler
11-21-05 18:55 KenCausey Relationship added has duplicate 0002247
12-10-05 15:31 pmm Issue Monitored: pmm
01-27-06 09:24 MarcusDenker Status new => closed
01-27-06 09:24 MarcusDenker Note Added: 0003637
01-27-06 09:24 MarcusDenker Resolution open => fixed
01-27-06 09:24 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
53 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker