Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002345 [Squeak] MVC major always 12-10-05 15:55 02-15-06 21:07
Reporter lewis View Status public  
Assigned To cdegroot
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0002345: Cannot open Workspace from world menu in MVC
Description "Workspace open" works fine, but opening a Workspace from the world menu in MVC does nothing at all.
Steps To Reproduce
Additional Information The problem is present in Squeak3.9a-6705, and not in Squeak3.9a-6695, so it entered some time after the MC1 change set.
Attached Files  MVCUIManagerMissingMethods-dtl.1.cs.gz [^] (612 bytes) 12-10-05 23:34

- Relationships
has duplicate 0002443closed  It is not possible to open Workspace in MVC 

- Notes
(0003272 - 359 - 371 - 371 - 371 - 371 - 371)
lewis
12-10-05 23:36

This appears to be just some missing (not yet implemented?) methods in MVCUIManager. I uploaded MVCUIManagerMissingMethods-dtl.1.cs.gz which adds the missing method, plus a couple of #notYetImplemented methods to mark two other missing implementations that could cause problems later on.

Maybe someone is already working on this, if so just disregard this.
 
(0003277 - 112 - 112 - 112 - 112 - 112 - 112)
andreas
12-11-05 06:27

I've added you as a developer at squeaksource.com. Feel free to commit these changes directly to the repository.
 
(0003288 - 63 - 63 - 63 - 63 - 63 - 63)
lewis
12-12-05 12:45

Thanks, I added the changes to ToolBuilder-MVC on squeaksource.
 
(0003306 - 301 - 313 - 313 - 313 - 313 - 313)
cdegroot
12-13-05 00:01

Did my own implementation that doesn't use Workspace - one of the idea of ToolBuilder is to help us get rid of the old stuff ;-).

Patch is in ToolBuilder-MVC-CdG.9 which is in my local package-cache pending confirmation by Andreas that he doesn't want/need to be involved in ToolBuilder patching...
 
(0003308 - 45 - 45 - 45 - 45 - 45 - 45)
cdegroot
12-13-05 00:52

Copied patch to squeaksource.com/ToolBuilder
 
(0003317 - 510 - 534 - 534 - 534 - 534 - 534)
lewis
12-13-05 12:11

Cees, your #edit:label:accept: opens a StringHolder rather than a Workspace, which means that e.g. workspace variable bindings do not work. Not Good.

Also FYI, I gummed up the works here by loading ToolBuilder-MVC-dtl.12 after ToolBuilder-MVC-ar.8 (because I entered wrong SqueakSource authentication several times). This messes up your ToolBuilder-MVC-CdG.9 version in the MC browser. Sorry about that.

Right now, ToolBuilder-MVC-dtl.12 shows up as the most recent version in MC. This version does work.
 
(0003874 - 7 - 7 - 7 - 7 - 7 - 7)
MarcusDenker
02-15-06 21:07

in 3.9a
 

- Issue History
Date Modified Username Field Change
12-10-05 15:55 lewis New Issue
12-10-05 23:34 lewis File Added: MVCUIManagerMissingMethods-dtl.1.cs.gz
12-10-05 23:36 lewis Note Added: 0003272
12-11-05 06:27 andreas Note Added: 0003277
12-12-05 12:45 lewis Note Added: 0003288
12-13-05 00:01 cdegroot Status new => resolved
12-13-05 00:01 cdegroot Resolution open => fixed
12-13-05 00:01 cdegroot Assigned To  => cdegroot
12-13-05 00:01 cdegroot Note Added: 0003306
12-13-05 00:52 cdegroot Note Added: 0003308
12-13-05 00:52 cdegroot Status resolved => assigned
12-13-05 00:52 cdegroot Status assigned => resolved
12-13-05 12:11 lewis Status resolved => feedback
12-13-05 12:11 lewis Resolution fixed => reopened
12-13-05 12:11 lewis Note Added: 0003317
02-11-06 19:05 MarcusDenker Relationship added has duplicate 0002443
02-15-06 21:07 MarcusDenker Status feedback => closed
02-15-06 21:07 MarcusDenker Note Added: 0003874
02-15-06 21:07 MarcusDenker Resolution reopened => fixed
02-15-06 21:07 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
75 total queries executed.
47 unique queries executed.
Powered by Mantis Bugtracker