Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002377 [Squeak] System minor always 12-17-05 14:38 01-19-06 18:04
Reporter lewis View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0002377: Cannot rename a project from its window menu
Description Make a new project, using its window menu --> 'change title...' results in a walkback. The problem is generated from Project>>windowReqNewLabel: which calls ChangeSet>>changeSetNamed: rather than ChangeSorter>>changeSetNamed:. This is a recent refactoring (by Andreas). It looks like there is an intent to move #changeSetNamed: from ChangeSorter to ChangeSet, and either it is not completely implemented, or the change crept in to 3.9a by mistake.
Steps To Reproduce
Additional Information
Attached Files  Project-windowRegNewLabel-klc.1.cs.gz [^] (329 bytes) 12-19-05 21:38

- Relationships
has duplicate 0002497closed  MNU when changing title on Morphic Project 

- Notes
(0003361 - 89 - 89 - 89 - 89 - 89 - 89)
KenCausey
12-19-05 21:38

Well, it seems to me a simple s/changeSetNamed:/named:/ does the job. See the changeset.
 
(0003555 - 15 - 15 - 15 - 15 - 15 - 15)
MarcusDenker
01-19-06 18:04

will be in 6716
 

- Issue History
Date Modified Username Field Change
12-17-05 14:38 lewis New Issue
12-17-05 14:38 lewis Status new => assigned
12-17-05 14:38 lewis Assigned To  => KenCausey
12-19-05 21:38 KenCausey File Added: Project-windowRegNewLabel-klc.1.cs.gz
12-19-05 21:38 KenCausey Note Added: 0003361
12-19-05 21:39 KenCausey Assigned To KenCausey =>
12-19-05 21:39 KenCausey Status assigned => feedback
12-19-05 21:39 KenCausey Category Any => System
01-16-06 21:53 KenCausey Relationship added has duplicate 0002497
01-19-06 18:04 MarcusDenker Status feedback => closed
01-19-06 18:04 MarcusDenker Note Added: 0003555
01-19-06 18:04 MarcusDenker Resolution open => fixed
01-19-06 18:04 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
52 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker