Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002912 [Squeak] SqueakMap major always 02-18-06 19:34 07-13-06 16:04
Reporter bp View Status public  
Assigned To gokr
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0002912: Error when updating map: SystemDictionary>>logChange:
Description 1. I created a clean Squeak directory, only VM, sources, and Squeak3.9a-6727.image and changes, without a sm subdirectory.
2. Open a transcript.
3. Open SqueakMap Package Loader.
4. Answer Yes when being asked whether to upgrade to 2.1.
5. I got the error.
Steps To Reproduce
Additional Information
Attached Files  SqueakDebug MessageNotUnderstood SystemDictionary logChange.log [^] (4,485 bytes) 02-18-06 19:34

- Relationships

SYSTEM WARNING: Creating default object from empty value

has duplicate 0003274closed gokr SqueakMap crash with SystemDictionary doesNotUnderstand: #logChange: 
has duplicate 0003283closed gokr Error upgrading SqueakMap 

- Notes
(0003904 - 142 - 148 - 148 - 148 - 148 - 148)
MarcusDenker
02-18-06 20:50

This is because SqueakMap calles those methods that where deprecated in 3.8a. Deprecated
methods get removed one release later (thus in 3.9a)
 

- Issue History
Date Modified Username Field Change
02-18-06 19:34 bp New Issue
02-18-06 19:34 bp Status new => assigned
02-18-06 19:34 bp Assigned To  => gokr
02-18-06 19:34 bp File Added: SqueakDebug MessageNotUnderstood SystemDictionary logChange.log
02-18-06 19:39 bp Issue Monitored: bp
02-18-06 20:50 MarcusDenker Note Added: 0003904
03-09-06 16:10 MarcusDenker Relationship added has duplicate 0003274
03-10-06 16:10 MarcusDenker Relationship added has duplicate 0003283
04-02-06 11:29 cdan Issue Monitored: cdan
07-13-06 16:04 MarcusDenker Status assigned => closed
07-13-06 16:04 MarcusDenker Resolution open => fixed
07-13-06 16:04 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
55 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker