Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0002921 [Squeak] Compiler major sometimes 02-19-06 20:18 02-20-06 09:24
Reporter bp View Status public  
Assigned To MarcusDenker
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0002921: Emergency evaluator when MNU
Description I have downloaded Squeak3.9a-6729.image
I tested a little bit.
Then I sent a message from a workspace which resulted in a MessageNotUnderstood.
Then I got a Emergency Evaluator.

The package Compiler-md.36 is marked as dirty. But the only changes seem to be the order of the class variable names. This seems to be the reason for the crash. Loading Compiler-md.36 again fixes the problem!
Steps To Reproduce
Additional Information I tried to reproduce this, i.e. making the Compiler package dirty - with a completely new image but I failed. :-( However, you can reproduce this with my image:
http://pieber.com/Squeak/Squeak3.9a-6727 [^] Emergency Evaluator.zip

Just execute 3 zork from the workspace.
Attached Files  3zork.gif [^] (12,388 bytes) 02-19-06 23:01

- Relationships

- Notes
(0003907 - 120 - 138 - 324 - 324 - 324 - 324)
bp
02-19-06 21:05
edited on: 02-19-06 21:06

Sorry for the blanks in the URL. Let's try this:
http://pieber.com/Squeak/Squeak3.9a-6727%20Emergency%20Evaluator.zip [^]

 
(0003908 - 589 - 667 - 667 - 667 - 667 - 667)
wiz
02-19-06 22:59

Ha, a good fun bug.

To reproduce,
OPEN a fresh 6727
From the world menu open a workspace.
Type:
3 zork
select and evaluate with (cmd-p)

the emergency evaluator will come on (see uploaded 3zork.gif for entrails).

Note the 6727 I used was the standard one from the ftp not the one offered here for downloading. So this is a solid bug find. And easily reproduced.

After it has gotten this out of its system squeak seems to be content to just raise the pre-debugger window. So this has probably to do with something that is not initialized properly in the initial image.
 
(0003909 - 91 - 91 - 91 - 91 - 91 - 91)
MarcusDenker
02-19-06 23:12

Can you try to repreduce with 6729? The error looks quite much like one I fixed in 6729...
 
(0003911 - 235 - 283 - 283 - 283 - 283 - 283)
wiz
02-20-06 07:53

Hi Marcus,

I tried the same provocation in 6729 as got the bug in 6727.

The results were different. Just the debug box no emergency.

So you may have found it.

I have not done (nor will I do) any extensive further testing.
 
(0003912 - 422 - 458 - 458 - 458 - 458 - 458)
bp
02-20-06 09:02

Hi Marcus,

I had downloaded 6729 and thought I had used it. However, I just verified that the image with the bug is indeed a version 6727 image. I tried at least half an hour to reproduce it in 6729. Now I know why I failed. :-(

I am very sorry about that! I hope it did not cost you too much time.

By the way, I was really amazed about the speed you responded to my last bug requests! Thanks for all your effort!
 
(0003913 - 5 - 5 - 5 - 5 - 5 - 5)
MarcusDenker
02-20-06 09:24

fixed
 

- Issue History
Date Modified Username Field Change
02-19-06 20:18 bp New Issue
02-19-06 21:02 bp Issue Monitored: bp
02-19-06 21:05 bp Note Added: 0003907
02-19-06 21:06 bp Note Edited: 0003907
02-19-06 22:59 wiz Note Added: 0003908
02-19-06 23:01 wiz File Added: 3zork.gif
02-19-06 23:12 MarcusDenker Note Added: 0003909
02-19-06 23:34 MarcusDenker Status new => assigned
02-19-06 23:34 MarcusDenker Assigned To  => MarcusDenker
02-20-06 07:53 wiz Note Added: 0003911
02-20-06 09:02 bp Note Added: 0003912
02-20-06 09:24 MarcusDenker Status assigned => closed
02-20-06 09:24 MarcusDenker Note Added: 0003913
02-20-06 09:24 MarcusDenker Resolution open => fixed
02-20-06 09:24 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
65 total queries executed.
42 unique queries executed.
Powered by Mantis Bugtracker