Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003035 [Squeak] VM minor always 02-22-06 11:21 09-18-07 09:19
Reporter MichaelPiel View Status public  
Assigned To andreas
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version
  Product Build
Summary 0003035: Socket>>receiveUDPDataInto: doesn't work under Windows
Description The Win32 VM function for Socket>>primSocket:receiveUDPDataInto:StartingAt:count: has a bug.

in file sqWin32NewNet.c of SocketPlugin the function sqSocketReceiveUDPDataBufCountaddressportmoreFlag doesn't receive any data:
...
  /* receive data */
  nRead = sqSocketSendDataBufCount(s, buf, bufSize);
...

This bug seems to be present in all win32 VMs since the function is implemented (at least 3.4).
Steps To Reproduce
Additional Information One can use Socket>>ReceiveDataInto: instead of Socket>>receiveUDPDataInto: since it checks if the socket is TCP or UDP.
Attached Files

- Relationships

- Notes
(0004553 - 93 - 93 - 93 - 93 - 93 - 93)
andreas
03-23-06 22:39

Oops. Good find, thanks. I've fixed it in the source code already, the next VMs will have it.
 
(0004583 - 5 - 5 - 5 - 5 - 5 - 5)
MarcusDenker
03-27-06 22:55

fixed
 
(0011141 - 306 - 351 - 351 - 351 - 351 - 351)
gaelli
09-18-07 09:05

Does not yet with windows VM 3.7.1

To reprodzuce load the latest OSC package from SqueakSource and run the tests on Windows -> bang.
On Apple the OSCServerTest works.

Using Socket>>receiveDataInto: instead of Socket>>receiveUDPDataInto: helps, but nonetheless this bug does not seem to be fixed yet.
 
(0011142 - 142 - 142 - 142 - 142 - 142 - 142)
andreas
09-18-07 09:19

Fixes don't apply to VMs that were released two years before the fix. Unless someone explains to me how to do the time-travel thing that is...
 

- Issue History
Date Modified Username Field Change
02-22-06 11:21 MichaelPiel New Issue
03-23-06 22:39 andreas Status new => resolved
03-23-06 22:39 andreas Resolution open => fixed
03-23-06 22:39 andreas Assigned To  => andreas
03-23-06 22:39 andreas Note Added: 0004553
03-27-06 22:55 MarcusDenker Status resolved => closed
03-27-06 22:55 MarcusDenker Note Added: 0004583
03-27-06 22:55 MarcusDenker Fixed in Version  => 3.9
09-18-07 09:05 gaelli Status closed => feedback
09-18-07 09:05 gaelli Resolution fixed => reopened
09-18-07 09:05 gaelli Note Added: 0011141
09-18-07 09:19 andreas Status feedback => closed
09-18-07 09:19 andreas Note Added: 0011142
09-18-07 09:19 andreas Resolution reopened => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
55 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker