Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003498 [Squeak] Tools minor always 04-24-06 03:00 04-26-06 11:15
Reporter nicolas cellier View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0003498: MessageTally fail to open result window [DNU] UndefinedObject contractTo:
Description This one fail:

| m |
m := MethodDictionary allInstances asSortedCollection: [:a :b | a size > b size].
MessageTally spyOn: [1 to: 10 do: [:i | (m at: i) rehash]]

This one does not fail:

| m |
m := MethodDictionary allInstances asSortedCollection: [:a :b | a size > b size].
MessageTally spyOn: [(1 to: 10) do: [:i | (m at: i) rehash]]

It must have something to do with open-coded messages in bytecode...
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0004780 - 100 - 100 - 100 - 100 - 100 - 100)
tim
04-24-06 03:23

Just tried this in a 3.9a7024 imag and both cases produce the expected tally window with no problem.
 
(0004782 - 620 - 744 - 870 - 870 - 870 - 870)
nicolas cellier
04-24-06 04:50

OK, a virgin image does not show it.
it is my correction of http://bugs.impara.de/view.php?id=3448 [^] in ParagraphEditor>>evaluateSelection that caused the problem.

It seem that the path i used does not fill correctly the last but one literal MethodProperties, thus making selector nil instead of #DoIt...
Problem does not show when using parenthesis, because UndefinedObject>>DoIt is replaced with Interval>>do: in the leaves...

So this one is closed concerning MessageTally.
But i can charge
    ParagraphEditor>>compileSelectionFor:in:
that fail to call:
    method selector ifNil: [method selector: #DoIt].
 
(0004815 - 6 - 6 - 6 - 6 - 6 - 6)
MarcusDenker
04-26-06 11:15

no bug
 

- Issue History
Date Modified Username Field Change
04-24-06 03:00 nicolas cellier New Issue
04-24-06 03:23 tim Note Added: 0004780
04-24-06 04:50 nicolas cellier Note Added: 0004782
04-26-06 11:15 MarcusDenker Status new => closed
04-26-06 11:15 MarcusDenker Note Added: 0004815
04-26-06 11:15 MarcusDenker Resolution open => fixed
04-26-06 11:15 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker