Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003511 [Squeak] System major always 04-27-06 19:53 07-12-06 22:47
Reporter chris View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0003511: FixUnderscores loses timeStamp information
Description Did the 3.9 team decide to adopt Berts underscore solution and, if so, is there a plan to run his conversion for 3.9 which converts the code from underscore assignment to :=?

If so, may we please preserve the old timestamp information? Since the change is only cosmetic, I think we would lose valuable historical information. Bert said it should be trivial to keep it and it was. Here is a new version of FixUnderscores which preserves it.

Thank you.
Steps To Reproduce
Additional Information
Attached Files  FixUnderscores-cmm.9.mcz [^] (3,718 bytes) 04-27-06 19:53

- Relationships
child of 0006432new  In some methods assignment shows as underscores. This needs to be fixed. 

- Notes
(0004820 - 52 - 52 - 52 - 52 - 52 - 52)
ducasse
04-29-06 21:52

thanks we will run this one instead of the other one
 
(0004841 - 89 - 89 - 89 - 89 - 89 - 89)
chris
05-02-06 04:03

FixUnderscores-cmm.10.mcz (or better) is at impara which handles nil timeStamps properly.
 
(0005823 - 5 - 5 - 5 - 5 - 5 - 5)
MarcusDenker
07-12-06 22:47

added
 

- Issue History
Date Modified Username Field Change
04-27-06 19:53 chris New Issue
04-27-06 19:53 chris File Added: FixUnderscores-cmm.9.mcz
04-29-06 21:52 ducasse Note Added: 0004820
05-02-06 04:03 chris Note Added: 0004841
07-12-06 22:47 MarcusDenker Status new => closed
07-12-06 22:47 MarcusDenker Note Added: 0005823
07-12-06 22:47 MarcusDenker Resolution open => fixed
07-12-06 22:47 MarcusDenker Fixed in Version  => 3.9
05-24-08 18:39 wiz Relationship added related to 0006432
05-24-08 18:40 wiz Relationship replaced child of 0006432


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
57 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker