Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003710 [Squeak] Morphic minor always 05-24-06 06:59 07-12-06 22:46
Reporter DF View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0003710: TransformMorphTest is annoying (and confusing)
Description TransformMorphTest is annoying because:
- leaves a Morph opened in the world.
- in the test uses ActiveHand to grab a morph
(a unit test is supposed to be run without user interaction).

And is confusing because: the test is called transform test.. but I don't known what is testing:
self shouldnt: [ActiveHand grabMorph: child.
        ActiveHand position: 10@10 + ActiveHand position.]
        raise: MessageNotUnderstood
If is testing the rotation of the morph is better to do another assertion.

NOTE TO THE MAINTAINER: I could fix it, but I don't known the intention of the test. Just tell me and I would upload a fix
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0005822 - 29 - 29 - 29 - 29 - 29 - 29)
MarcusDenker
07-12-06 22:46

fixed by deletion of TestCase
 

- Issue History
Date Modified Username Field Change
05-24-06 06:59 DF New Issue
05-24-06 07:14 DF Issue Monitored: DF
07-12-06 22:46 MarcusDenker Status new => closed
07-12-06 22:46 MarcusDenker Note Added: 0005822
07-12-06 22:46 MarcusDenker Resolution open => fixed
07-12-06 22:46 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
37 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker