Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003718 [Squeak] Morphic minor always 05-25-06 23:44 07-14-06 15:42
Reporter DF View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.9
  Product Build
Summary 0003718: Failures in BlockContextTest>>testSupplyAnswer*
Description Tests on BlockContextTest (and subclasses) that involves the messages #valueSupplyingAnswer: and #valueSupplyingAnswers: , fails because:

The test uses [ self confirm: 'bla bla' ] valueSupplyingAnswer: ...

But #valueSupplyingAnswer: supplies an answer only if the block signals ProvideAnswerNotification, in other case returns the result of the block.
Object>>confirm: never raises ProvideAnswerNotification, so the result is the result of the confirmation. (so the test is not testing the implementation of valueSupplyingAnswer: and the success depends on the response to the confirmation)

Solution proposals:

(1) Change the test and the comment of #valueSupplyingAnswers: to indicate that it applies only to block that signals ProvideAnswerNotification.
Modify the test, to be like this:
self should: [[ ProvideAnswerNotification signal: 'Smalltalk' ] valueSupplyingAnswer: #('Smalltalk' true) ]

(2) Change Object>>confirm: to signal ProvideAnswerNotification.

(3) In my image (3.9b-7032) the only sender of #valueSupplyingAnswers: is the test. I don't known if this message is used by other packages, but since this is used only by FillInTheBlankMorph, I think that #valueSupplyingAnswers: belongs to the FillInTheBlankMorph and not to BlockContext!

In either case is convenient that test didn't display any confirmation dialog. (tests must run without user interaction)

With this bug report I have included a change set to implement the solution (1), because is easier to do. But I prefer the solution no. (3)
Steps To Reproduce
Additional Information
Attached Files  BlockContextTestValueSupplyingAnswer.1.cs [^] (2,083 bytes) 05-25-06 23:44

- Relationships
related to 0003719closed  Test BlockContextTest>>testSuppressInform* are incorrect 

- Notes
(0005898 - 5 - 5 - 5 - 5 - 5 - 5)
MarcusDenker
07-14-06 15:42

fixed
 

- Issue History
Date Modified Username Field Change
05-25-06 23:44 DF New Issue
05-25-06 23:44 DF File Added: BlockContextTestValueSupplyingAnswer.1.cs
05-25-06 23:46 DF Issue Monitored: DF
05-26-06 00:06 KenCausey Relationship added related to 0003719
07-14-06 15:42 MarcusDenker Status new => closed
07-14-06 15:42 MarcusDenker Note Added: 0005898
07-14-06 15:42 MarcusDenker Resolution open => fixed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker