Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003747 [Squeak] Morphic minor always 05-31-06 19:43 07-14-06 16:32
Reporter Ron View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0003747: TransformMorph crashes when picked up by handMorph after scaleFactor: is called
Description I placed a rectangleMorph inside a pasteUpMorph, then called scaleFactor: 1.5. When I tried to pick up the rectangleMorph it exploded, in one case it started flickering and blew up the image.

Running image 3.9b+7032

a HandMorph does not have a transformMorph as a submorph so remove flex shell fails because position is nil. Since hand morph is now holding onto the morph assuming a 1 when nil as in the case when a handmorph is holding the transformMorph fixes the problem.

Attached is a st file with a potential fix which simply adds an if nil check to TransformationMorph>>removeFlexShell

aPosition _ (owner submorphIndexOf: self) ifNil: [1].

-Ron Teitelbaum Ron@USMedRec.com
Steps To Reproduce
Additional Information
Attached Files  TransformationMorph-removeFlexShell.st [^] (1,173 bytes) 05-31-06 19:43

- Relationships

- Notes
(0005902 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
07-14-06 16:32

7044
 

- Issue History
Date Modified Username Field Change
05-31-06 19:43 Ron New Issue
05-31-06 19:43 Ron File Added: TransformationMorph-removeFlexShell.st
07-14-06 16:32 MarcusDenker Status new => closed
07-14-06 16:32 MarcusDenker Note Added: 0005902
07-14-06 16:32 MarcusDenker Resolution open => fixed
07-14-06 16:32 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
37 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker