Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000381 [Squeak] Any major always 10-14-04 03:16 11-20-04 01:13
Reporter laza View Status public  
Assigned To laza
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version Product Version
  Product Build
Summary 0000381: EventTicklerProcess blocked by long delay
Description Even if the EventTicklerProcess gets started on image startup it is blocked by a very long delay in the attached image.

At one time when I looked at the Delay inside the EventTicklerProcess the resumption time was 2982694 and Time millisecondClockValue 2188761, so about 700 seconds delay time.
Steps To Reproduce
Additional Information Windows XP
3.6, 3.7 VM
3.8a(6297)
Attached Files

- Relationships

- Notes
(0000376 - 163 - 187 - 323 - 323 - 323 - 323)
laza
10-14-04 03:22

The Archive seems to be too large. Here is a link to the image:

http://www.lazarevic.de/Squeak3.8a-5987.zip [^]

(Despite the name the image is updated upto 6297)
 
(0000382 - 431 - 494 - 494 - 494 - 494 - 494)
laza
10-14-04 11:09
edited on: 10-14-04 11:21

To see that there is something wrong in 3.8a evaluate this:

Duration milliSeconds: (Sensor eventTicklerProcess suspendedContext receiver resumptionTime - Time millisecondClockValue)

In a 3.7 image I get the expected random values <500ms.
In a saved 3.8a image I get values upto 30 minutes!
An image updated from 3.7 to 3.8a (without saving the image) gives something like that:

-0:01:10:01.905

edited on: 10-14-04 11:21
 
(0000419 - 77 - 89 - 89 - 89 - 89 - 89)
laza
10-16-04 23:36

The problem shows up after this update

6295RestartTimerInterruptWatcher-nk
 
(0000448 - 173 - 212 - 212 - 212 - 212 - 212)
andreas
10-18-04 09:55

Yup, it looks as if the event sensor delay was just active when the timer interrupt got restarted. Simply evaluating:

   EventSensor install.

Should do the trick - ar.
 
(0000508 - 57 - 57 - 57 - 57 - 57 - 57)
tim
10-22-04 03:43

Didn't this get resolved? Or was I imagining the emails?
 
(0000514 - 161 - 167 - 167 - 346 - 346 - 346)
laza
10-22-04 11:27

The bug reported for 3.7 in 0000371 gets correctly fixed with update 6293.
In my bugnote there I confused the bug with the one I now reported here for 3.8a in 0000381
 
(0000717 - 34 - 37 - 37 - 37 - 37 - 37)
laza
11-20-04 01:13

Seems to be fixed in 3.8b(>=6461).
 

- Issue History
Date Modified Username Field Change
10-14-04 03:16 laza New Issue
10-14-04 03:22 laza Note Added: 0000376
10-14-04 11:09 laza Note Added: 0000382
10-14-04 11:21 laza Note Added: 0000383
10-14-04 11:21 laza Note Deleted: 0000383
10-14-04 11:21 laza Note Edited: 0000382
10-16-04 23:36 laza Note Added: 0000419
10-18-04 09:55 andreas Note Added: 0000448
10-22-04 03:43 tim Note Added: 0000508
10-22-04 11:27 laza Note Added: 0000514
11-20-04 01:13 laza Note Added: 0000717
11-20-04 01:13 laza Status new => resolved
11-20-04 01:13 laza Resolution open => fixed
11-20-04 01:13 laza Assigned To  => laza
11-20-04 01:13 laza Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
71 total queries executed.
45 unique queries executed.
Powered by Mantis Bugtracker