Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000384 [Croquet] Jasmine major always 10-14-04 08:36 10-18-04 18:50
Reporter jmegq View Status public  
Assigned To bert
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Product Build
Summary 0000384: Big TMorphMonitor bug when a dialog is popped up
Description In any of the Croquet windows that have 2d squeak content in them (e.g., Chess, Scampers, etc.), this bug occurs. If any action is performed that results in a dialog being brought up, the entire Croquet TeapotMorph starts behaving strangely: (1) the world no longer redraws when idle, but only when you are moving; (2) the UI buttons don't work [e.g., exit from the ButtonOverlay]; (3) portals don't work. Middle-clicking (sorry, which color is that?) to bring up halos allows me to destroy the space, and problems are gone in a new instance of TeapotMorph.
Steps To Reproduce
Additional Information I haven't checked, but I believe the 2d windows in question are using TMorphMonitor to draw in Croquet-land. One sure-fire way to get this bug to appear for me is to go Underwater and click on the menu-button in the upper-right corner of either of the scamper-browser windows. Another is to go to Chess, pop up a World menu inside it, and click on an action that puts up a dialog, such as "Save as..."
Attached Files

- Relationships

- Notes
(0000387 - 402 - 432 - 432 - 432 - 432 - 432)
samy
10-14-04 20:28

Doesn't happen with every dialog for me.
The scamper menu button will trigger the bug, open... file and help... about in the world menu will too. But for example the other dialogs which can be opened from the open.. menu come up without problem.

All other symptoms are the same.

This is on winxp / nvidia ge5200fx (not so current drivers) with the squeak version that was included with jasmine.
 
(0000455 - 68 - 68 - 68 - 191 - 191 - 191)
jmegq
10-18-04 17:41

Fixed in latest updates (for 0000400), probably change set 81. Thanks!
 

- Issue History
Date Modified Username Field Change
10-14-04 08:36 jmegq New Issue
10-14-04 17:25 samy Issue Monitored: samy
10-14-04 20:28 samy Note Added: 0000387
10-18-04 17:41 jmegq Note Added: 0000455
10-18-04 18:50 bert Status new => resolved
10-18-04 18:50 bert Resolution open => fixed
10-18-04 18:50 bert Assigned To  => bert


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
43 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker