Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003878 [Squeak] SmaCC major N/A 06-25-06 00:15 07-12-06 20:22
Reporter mathk View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0003878: SmaCCToken don't initialize start atribut correctly
Description When you inspect a RBMethodNode build like this:

-----------------------------------------
| ir ast |
ir _ IRBuilder new
       numRargs: 1;
       addTemps: #(self);
       "pushTemp: #self;"
       pushLiteral: 3;
       pushLiteral: 2;
       send: #+;
       pushLiteral: 2;
       send: #*;
       send: #factorial;
       returnTop;
       ir.

ast _ IRDecompiler new decompileIR: ir
-----------------------------------------


There is a bug when clicking on 'all inst vars'.
This is due to a bad initialization in SmaCCToken I think.
The 'start' atribut is nil by default.
But a number is expected. So I think is beter to initialize 'start' with 0.
Steps To Reproduce
Additional Information You have to install the NewCompiler and all dependency befor execute the sample.
Attached Files

- Relationships
has duplicate 0003877closed KenCausey SmaCCToken don't initialize start atribut correctly 

- Notes
(0005811 - 18 - 18 - 18 - 18 - 18 - 18)
MarcusDenker
07-12-06 20:22

is in SqueakSource
 

- Issue History
Date Modified Username Field Change
06-25-06 00:15 mathk New Issue
06-25-06 00:15 mathk Status new => assigned
06-25-06 00:15 mathk Assigned To  => KenCausey
06-25-06 00:17 mathk Issue Monitored: mathk
06-26-06 20:31 KenCausey Relationship added has duplicate 0003877
06-26-06 20:45 KenCausey Assigned To KenCausey =>
06-26-06 20:45 KenCausey Status assigned => new
06-26-06 20:45 KenCausey Category Any => SmaCC
07-12-06 20:22 MarcusDenker Status new => closed
07-12-06 20:22 MarcusDenker Note Added: 0005811
07-12-06 20:22 MarcusDenker Resolution open => fixed
07-12-06 20:22 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
35 unique queries executed.
Powered by Mantis Bugtracker