Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003887 [Squeak] Collections text always 06-26-06 09:17 07-14-06 12:07
Reporter Damien Cassou View Status public  
Assigned To
Priority normal Resolution fixed Platform Windows
Status closed   OS Windows
Projection none   OS Version XP
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build 3.9b-7035
Summary 0003887: SequenceableCollection>>, wrong comment
Description In the comment, there is an example for using #,:

((2989 printStringBase: 16) copyFrom: 4 to: 6) , ' boy!'

This answer a 'Subscript out of bounds: 4'.

(2989 printStringBase: 16) evaluates to 'BAD'. Then #copyFrom:to: is out of bounds.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0005384 - 515 - 628 - 628 - 628 - 628 - 628)
wiz
06-27-06 07:18

'16rBAD' is the intended result of
(2989 printStringBase: 16 )
The bug is that it evaluates to 'BAD'.

This worked according to the commment in Squeak 2.7.
And 'BAD'ly in 3.8-6665 and 3.9b-7035.

This fragment from a FractionTest


self assert: ((109/113) printStringBase: 16) = '(6D/71)'.
    self assert: ((109/113) storeStringBase: 16) = '(16r6D/16r71)'.

seems to indicate the change is deliberate and the comment should be changed to use #storeStringBase: .

I leave the changing of it to you.
 
(0005881 - 4 - 4 - 4 - 4 - 4 - 4)
MarcusDenker
07-14-06 12:07

7043
 

- Issue History
Date Modified Username Field Change
06-26-06 09:17 Damien Cassou New Issue
06-27-06 07:18 wiz Note Added: 0005384
07-14-06 12:07 MarcusDenker Status new => closed
07-14-06 12:07 MarcusDenker Note Added: 0005881
07-14-06 12:07 MarcusDenker Resolution open => fixed
07-14-06 12:07 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
40 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker