Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0003908 [Squeak] Browser minor always 06-27-06 15:59 07-13-06 15:58
Reporter dpollet View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.9 Product Version 3.9
  Product Build
Summary 0003908: typos in pretty-printing code
Description in 7035 with AST 57 loaded...
these were working but not in the intended way... see the FIX comments

Behavior>> formatterClass
    ^Preferences useRBASTForPrettyPrint "FIX: added AST, since this is the preference name"
        ifFalse: [ self compilerClass ]
        ifTrue: [ RBParser ]

Behavior>> prettyPrinterClass
    ^Preferences useRBASTForPrettyPrint "FIX: idem"
        ifFalse: [ self compilerClass ]
        ifTrue: [ RBParser ]

ParagraphEditor>> prettyPrint: decorated
    "Reformat the contents of the receiver's view (a Browser)."

    | selectedClass newText |
    model selectedMessageCategoryName ifNil: [^ view flash].
    selectedClass := model selectedClassOrMetaClass.
    newText := selectedClass prettyPrinterClass "FIX: new removed here, since the following method is defined on the class side"
        format: self text
        in: selectedClass
        notifying: self
        decorated: decorated.
    newText ifNotNil:
        [self deselect; selectInvisiblyFrom: 1 to: paragraph text size.
        self replaceSelectionWith: (newText asText makeSelectorBoldIn: selectedClass).
        self selectAt: 1]
Steps To Reproduce
Additional Information this is my 1st report here... I tried to file out the changes but those of Behavior don't go in the .cs file... strange
Attached Files

- Relationships

- Notes
(0005841 - 69 - 81 - 81 - 81 - 81 - 81)
MarcusDenker
07-13-06 15:58

RB fixes are in AST-md.69 (SqueakSource)

Image fix will be in 7042
 

- Issue History
Date Modified Username Field Change
06-27-06 15:59 dpollet New Issue
07-13-06 15:58 MarcusDenker Status new => closed
07-13-06 15:58 MarcusDenker Note Added: 0005841
07-13-06 15:58 MarcusDenker Resolution open => fixed
07-13-06 15:58 MarcusDenker Fixed in Version  => 3.9


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
35 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker