Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0004309 [Squeak] Compiler minor always 07-21-06 16:57 05-12-14 22:19
Reporter kwl View Status public  
Assigned To nicolas cellier
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version 3.9
  Product Build
Summary 0004309: Compiler/Parser allows undefined variable when LHS to :=
Description The following snippet does NOT raise an error message:

 | tmp1 tmp2 |
  tmp1 := 2.
  tmp2 := tmp2 + tmp1

But the following modification DOES raise an "undefined. proceed?" dialog

 | tmp1 tmp2 |
  tmp1 := 2.
  tmp1 := tmp2 + tmp1

Tested with 3.8 + 3.9.

Note that the error message should speak about "uninitialized" instead of "undefined" because the variables are indeed between the |'s.
Steps To Reproduce
Additional Information There can only be ONE rule for what is uninitialized and what is initialized, regardless of how a variable is used "mentioned" for the first time on the RHS of an expression.
Attached Files

- Relationships

- Notes
(0014499 - 102 - 102 - 102 - 102 - 102 - 102)
nicolas cellier
05-12-14 22:19

This is no more true in Squeak 4.5, and probably has been fixed for a long time now (Eliot's closure?)
 

- Issue History
Date Modified Username Field Change
07-21-06 16:57 kwl New Issue
05-12-14 22:19 nicolas cellier Status new => resolved
05-12-14 22:19 nicolas cellier Fixed in Version  => trunk
05-12-14 22:19 nicolas cellier Resolution open => fixed
05-12-14 22:19 nicolas cellier Assigned To  => nicolas cellier
05-12-14 22:19 nicolas cellier Note Added: 0014499


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
36 total queries executed.
31 unique queries executed.
Powered by Mantis Bugtracker