Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005608 [Squeak] Morphic minor always 12-05-06 19:38 01-07-09 16:54
Reporter pf View Status public  
Assigned To matthewf
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.10
  Product Build
Summary 0005608: preference #menuTitleBorderWidth - MenuMorph bugfix
Description I corrected method #addTitle:icon:updatingSelector:updateTarget: in
MenuMorph (deleted one line).

Fix is attached. Could be this fix included in 3.9 final version?
Steps To Reproduce
Additional Information
Attached Files  MenuMorph-addTitleiconupdatingSelectorupdateTarget.st [^] (1,690 bytes) 12-05-06 19:38

- Relationships

SYSTEM WARNING: Creating default object from empty value

related to 0006687assigned matthewf MenuMorphs are too easy to pick up 
related to 0001780pending matthewf Stay up menus have a confusing and dangerous behavior when obscured. 
child of 0006530new  A mother for button, slider and menuItem targeting and argumenting related reports. 

- Notes
(0011273 - 137 - 137 - 137 - 137 - 137 - 137)
matthewf
10-09-07 22:48

This was added to 3.10 as Morphic-edc.130.mcz. It is in the update stream at 7157MenuMorph-addTitleiconupdatingSelectorupdateTarget-pf.cs
 
(0011274 - 142 - 142 - 142 - 142 - 142 - 142)
matthewf
10-09-07 22:57

I don't like this change. It makes menu title bars look ugly imho. But, since it is now controled by the active ColorTheme, it is configurable
 
(0011275 - 87 - 87 - 87 - 174 - 174 - 174)
matthewf
10-09-07 22:58

This change modifies one of the same methods as 0006687. The change set there was updated
 
(0011700 - 87 - 125 - 125 - 245 - 245 - 245)
matthewf
01-22-08 06:45

This change is fixed in 0001780
"fix begin"
Installer mantis ensureFix: 1780
"fix end"
 
(0012903 - 48 - 48 - 48 - 48 - 48 - 48)
KenCausey
01-07-09 16:54

Harvested as update 7158 and released with 3.10.
 

- Issue History
Date Modified Username Field Change
12-05-06 19:38 pf New Issue
12-05-06 19:38 pf File Added: MenuMorph-addTitleiconupdatingSelectorupdateTarget.st
12-05-06 19:50 pf Issue Monitored: pf
10-07-07 21:15 matthewf Relationship added child of 0006530
10-07-07 21:15 matthewf Status new => assigned
10-07-07 21:15 matthewf Assigned To  => matthewf
10-09-07 20:38 edgardec Status assigned => resolved
10-09-07 20:38 edgardec version 3.9 => 3.10
10-09-07 22:37 matthewf Relationship added related to 0006687
10-09-07 22:37 matthewf Note Added: 0011272
10-09-07 22:42 matthewf Note Deleted: 0011272
10-09-07 22:48 matthewf Note Added: 0011273
10-09-07 22:57 matthewf Note Added: 0011274
10-09-07 22:58 matthewf Note Added: 0011275
10-09-07 23:17 matthewf Relationship added related to 0001780
01-22-08 06:45 matthewf Note Added: 0011700
01-07-09 16:54 KenCausey Status resolved => closed
01-07-09 16:54 KenCausey Note Added: 0012903
01-07-09 16:54 KenCausey Resolution open => fixed
01-07-09 16:54 KenCausey Fixed in Version  => 3.10


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
93 total queries executed.
61 unique queries executed.
Powered by Mantis Bugtracker