Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005619 [Squeak] Morphic crash always 12-08-06 02:29 09-08-08 17:36
Reporter wiz View Status public  
Assigned To wiz
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.9
  Product Build
Summary 0005619: {Fix] [Test] In 7067 (and before) sending #heading to a TransformationMorph w/o a rendee recurses infinitly
Description In a workspace evaluate
"TransformationMorph new openCenteredInWorld heading"

use Cmd-dot to stop the recursion.

Same bug is present for #heading:,
#forwardDirection, and #forwardDirection: .
Steps To Reproduce
Additional Information I found this while browsing code.

Coming across this bug in the wild is fairly rare but it can happen.

The rendered morph can be deleted leaving a naked TMorph to field rotation requests. I ran into it while trying to fix rotation for polygons.

(With out a renderer rotating correctly requires requesting your submorphs rotate as well.)

A fix is in the works and will be uploaded after some reassuring tests.

Yours in service, --Jerome Peace
Attached Files  RenderBugz.1.cs [^] (3,236 bytes) 12-08-06 03:49
 ForwardDirFix-wiz.5.cs [^] (2,150 bytes) 12-08-06 03:50
 setHeadingFix-wiz.1.cs [^] (487 bytes) 04-18-07 20:25

- Relationships
related to 0006429closed  [Fix ] Test suite could not run tests because they didn't follow naming convention. 

- Notes
(0008628 - 331 - 367 - 367 - 367 - 367 - 367)
wiz
12-08-06 03:55

Uploaded the tests and the fix.

I was able to get the tests to catch the recursion and properly cleanup after itself.

The fix addresses the four accessors and does a minor refactoring for #renderedMorph. No reason to test in Morph when an overide in the rendering classes is more elegant.

Yours in service, Jerome Peace
 
(0010567 - 88 - 94 - 94 - 94 - 94 - 94)
edgardec
04-17-07 12:13

This now is part of 7080wizFixesOfMorph.cs and was in updates for 3.10
Thanks Jerome !
 
(0010577 - 173 - 185 - 185 - 185 - 185 - 185)
wiz
04-18-07 20:29

missed one of the patches (the one for #heading:) which is now uploaded here.
It has also been uploaded to the related issue (the test fixes).
It is here for completeness.
 
(0011459 - 58 - 58 - 58 - 58 - 58 - 58)
matthewf
11-24-07 16:56

Reminder sent to: edgardec

Has this issue been fixed? I cannot tell from the comments
 
(0011462 - 167 - 173 - 173 - 173 - 173 - 173)
edgardec
11-24-07 19:49

TransformationMorph new openCenteredInWorld heading don't gives me any funny, maybe Jerome have some to say, but seems solved.
This is for Squeak3.10.1beta.7155.image
 
(0011470 - 104 - 104 - 104 - 104 - 104 - 104)
wiz
11-24-07 21:29

I checked the fix is in sq7155. The tests all pass and nothing recurses infinitly which was the problem.
 
(0011471 - 43 - 43 - 43 - 43 - 43 - 43)
wiz
11-24-07 21:30

Fixed in sq 7155 (or maybe a little before)
 
(0012592 - 117 - 123 - 123 - 123 - 123 - 123)
KenCausey
09-08-08 17:36

Harvested in update 7080 except TransformationMorph>>heading: harvested in update 7116 both included in 3.10 release.
 

- Issue History
Date Modified Username Field Change
12-08-06 02:29 wiz New Issue
12-08-06 03:49 wiz File Added: RenderBugz.1.cs
12-08-06 03:50 wiz File Added: ForwardDirFix-wiz.5.cs
12-08-06 03:55 wiz Note Added: 0008628
04-17-07 12:13 edgardec Note Added: 0010567
04-17-07 12:16 edgardec Note Added: 0010569
04-18-07 00:19 wiz Status new => resolved
04-18-07 00:19 wiz Resolution open => fixed
04-18-07 00:19 wiz Fixed in Version  => 3.10
04-18-07 20:25 wiz File Added: setHeadingFix-wiz.1.cs
04-18-07 20:26 wiz Relationship added related to 0006429
04-18-07 20:29 wiz Status resolved => feedback
04-18-07 20:29 wiz Resolution fixed => reopened
04-18-07 20:29 wiz Note Added: 0010577
11-24-07 16:56 matthewf Issue Monitored: edgardec
11-24-07 16:56 matthewf Note Added: 0011459
11-24-07 19:43 edgardec Note Deleted: 0010569
11-24-07 19:49 edgardec Note Added: 0011462
11-24-07 21:29 wiz Note Added: 0011470
11-24-07 21:30 wiz Status feedback => resolved
11-24-07 21:30 wiz Resolution reopened => fixed
11-24-07 21:30 wiz Assigned To  => wiz
11-24-07 21:30 wiz Note Added: 0011471
09-08-08 17:36 KenCausey Status resolved => closed
09-08-08 17:36 KenCausey Note Added: 0012592


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
90 total queries executed.
50 unique queries executed.
Powered by Mantis Bugtracker