Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006340 [Squeak] Kernel minor always 03-13-07 11:50 09-11-08 18:11
Reporter loewis View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.9
  Product Build
Summary 0006340: Smalltalk specialObjectsArray fails to print
Description Smalltalk specialObjectsArray fails to print and inspect, because object 36 is a MethodContext with a nil method. This change detects that case and processes it appropriately
Steps To Reproduce
Additional Information
Attached Files  printspecialobjectsfix.1.cs [^] (847 bytes) 03-13-07 11:50

- Relationships

- Notes
(0010675 - 86 - 118 - 118 - 118 - 118 - 118)
Keith_Hodges
05-08-07 13:56

"fix begin"
Installer mantis bug: 6340 fix: 'printspecialobjectsfix.1.cs'.
"fix end"
 
(0012639 - 46 - 46 - 46 - 46 - 46 - 46)
KenCausey
09-11-08 18:11

Harvested as update 7098 and included in 3.10.
 

- Issue History
Date Modified Username Field Change
03-13-07 11:50 loewis New Issue
03-13-07 11:50 loewis File Added: printspecialobjectsfix.1.cs
03-20-07 23:03 loewis Issue Monitored: loewis
05-08-07 13:56 Keith_Hodges Note Added: 0010675
09-11-08 18:11 KenCausey Status new => closed
09-11-08 18:11 KenCausey Note Added: 0012639
09-11-08 18:11 KenCausey Resolution open => fixed
09-11-08 18:11 KenCausey Fixed in Version  => 3.10


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker