Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006409 [Squeak] Collections major always 04-11-07 04:55 09-08-08 15:05
Reporter wiz View Status public  
Assigned To wiz
Priority urgent Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.10
  Product Build
Summary 0006409: in 7081 :7076fixPositionableStream-isEmpty.1.cs was wrong fix. Prettyprint broken by it.
Description For this one:

In a Fresh 7081

get a browser.
select a class and keyword method w/ an argument
(I used Kernel-Object>Object>Model>#trash:)
on the button bar change "source" to "pretty print"

debug box for lists must be the same size.

#trash: keywords returns #('trash:' '' ) which is not size = 1 as it should be.
Steps To Reproduce
Additional Information See 0002273 comments seems to indicate wrong fix file chosen.

Yours in service, -Jerome Peace
Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

has duplicate 0006405closed KenCausey String>>keywords implementation is based on wrong behavior of PositionableStream>>isEmpty 
child of 0002273closed  PositionableStream >>isEmpty retuns wrong result 

- Notes
(0010520 - 43 - 55 - 55 - 55 - 55 - 55)
wiz
04-11-07 05:03

Reminder sent to: edgardec

to the drawing board vamanos

Cheers -wiz
 
(0010521 - 52 - 52 - 180 - 180 - 180 - 180)
Damien Cassou
04-11-07 06:57

Duplicate of http://bugs.squeak.org/view.php?id=6405 [^]
 
(0012588 - 43 - 43 - 43 - 43 - 43 - 43)
KenCausey
09-08-08 15:05

Duplicate of 6405, harvested in update 7083
 

- Issue History
Date Modified Username Field Change
04-11-07 04:55 wiz New Issue
04-11-07 04:55 wiz Status new => assigned
04-11-07 04:55 wiz Assigned To  => KenCausey
04-11-07 04:57 wiz Assigned To KenCausey =>
04-11-07 04:57 wiz Category Any => Collections
04-11-07 04:57 wiz Relationship added child of 0002273
04-11-07 05:01 wiz Status assigned => new
04-11-07 05:01 wiz Assigned To  => wiz
04-11-07 05:03 wiz Issue Monitored: edgardec
04-11-07 05:03 wiz Note Added: 0010520
04-11-07 06:53 Damien Cassou Issue Monitored: Damien Cassou
04-11-07 06:57 Damien Cassou Note Added: 0010521
04-12-07 23:52 wiz Relationship added duplicate of 0006405
04-12-07 23:54 wiz Duplicate ID 0 => 6405
04-12-07 23:54 wiz Status new => resolved
04-12-07 23:54 wiz Resolution open => fixed
04-12-07 23:54 wiz Fixed in Version  => 3.10
09-08-08 15:05 KenCausey Relationship replaced has duplicate 0006405
09-08-08 15:05 KenCausey Status resolved => closed
09-08-08 15:05 KenCausey Note Added: 0012588


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
68 total queries executed.
43 unique queries executed.
Powered by Mantis Bugtracker