Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006446 [Squeak] ToolBuilder minor always 04-24-07 13:07 04-18-10 22:07
Reporter edgardec View Status public  
Assigned To wiz
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.10
  Product Build
Summary 0006446: Workspace with contents in Mac not always works well
Description Some text files with lf into have as result a Workspace window with bad formated text
The attached file solves the problem
Steps To Reproduce
Additional Information
Attached Files  FileList-viewContentsInWorkspace.st [^] (538 bytes) 04-24-07 13:07

- Relationships

- Notes
(0010614 - 80 - 92 - 92 - 92 - 92 - 92)
edgardec
04-24-07 13:10

Reminder sent to: wiz

Jerome, I think what send mail about this.
I solve and wish you look.
Thanks !
 
(0010616 - 934 - 1060 - 1158 - 1158 - 1158 - 1158)
wiz
04-26-07 00:58

Hi Edgar,

I do not do much cross platform work in squeak so I don't run into the translation problem.

And I don't have a very good way of handling it.

On my iMac I use a shareware editor called texedit :

http://www.tex-edit.com/ [^]

Which has been very cross platform aware and knows to translate from pc to unix to mac fairly well.

I mention this because it is provides some nice external tools for translating line endings etc. Not a bad research tool for font and character set stuff. (It also has spanish versions)

The things I am aware of are:

Mac's tend to use mac roman in their font sets. Squeak started out in mac roman and is now suppose to be standardized to latin-1 and whatever the I18n stuff requires. The problem you describe sounds like it falls into that catagory.

Hth, -Jer

------
Are the problems only with line endings or do the quote marks look funny also? Maybe upload a problem file?
 

- Issue History
Date Modified Username Field Change
04-24-07 13:07 edgardec New Issue
04-24-07 13:07 edgardec File Added: FileList-viewContentsInWorkspace.st
04-24-07 13:10 edgardec Issue Monitored: wiz
04-24-07 13:10 edgardec Note Added: 0010614
04-26-07 00:58 wiz Note Added: 0010616
09-20-07 02:50 wiz Status new => resolved
09-20-07 02:50 wiz Fixed in Version  => 3.10
09-20-07 02:50 wiz Resolution open => fixed
09-20-07 02:50 wiz Assigned To  => wiz
04-18-10 22:07 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
46 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker