Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006512 [Squeak] Kernel tweak N/A 05-25-07 13:14 11-20-08 20:35
Reporter gokr View Status public  
Assigned To
Priority low Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.9
  Product Build
Summary 0006512: Much faster printString (and thus also asString) for SmallIntegers
Description One override of #printString for SmallInteger and a new method for counting digits in base 10. This makes #printString for SmallIntegers more than 4 times faster than before.
Steps To Reproduce
Additional Information
Attached Files  FastSmallIntegerPrintString.1.cs.gz [^] (1,006 bytes) 05-25-07 13:14
 FastSmallIntegerPrintString.2.cs.gz [^] (1,196 bytes) 05-25-07 13:36

- Relationships
related to 0006887closed nicolas cellier Faster printString for LargeInteger 

- Notes
(0010756 - 52 - 52 - 52 - 52 - 52 - 52)
gokr
05-25-07 13:36

Added a second version with an added test method. :)
 
(0010897 - 84 - 90 - 90 - 90 - 90 - 90)
edgardec
07-19-07 20:18

This now is 7124FastSmallIntegerPrintString.cs and is in the updates
Thanks Goran !
 
(0011812 - 105 - 153 - 153 - 153 - 153 - 153)
nicolas cellier
02-15-08 22:06

"fix begin"
Installer mantis bug: 6512 fix: 'FastSmallIntegerPrintString.2.cs.gz'
"fix test"
"fix end"
 
(0011813 - 139 - 151 - 151 - 237 - 237 - 237)
nicolas cellier
02-15-08 22:08
edited on: 02-15-08 22:09

Just added Installer instructions because this change is a pre-requisite for 0006887, and might be missing in versions older than 3.10 7124

 
(0012475 - 115 - 129 - 381 - 381 - 381 - 381)
ducasse
08-09-08 08:25

added in pharo 10053
http://code.google.com/p/pharo/issues/detail?id=74&can=1&colspec=ID%20Type%20Status%20Summary [^]
 
(0012790 - 55 - 55 - 55 - 55 - 55 - 55)
KenCausey
11-20-08 20:35

Harvested in update 7124 and released with Squeak 3.10.
 

- Issue History
Date Modified Username Field Change
05-25-07 13:14 gokr New Issue
05-25-07 13:14 gokr File Added: FastSmallIntegerPrintString.1.cs.gz
05-25-07 13:36 gokr File Added: FastSmallIntegerPrintString.2.cs.gz
05-25-07 13:36 gokr Note Added: 0010756
07-19-07 20:18 edgardec Note Added: 0010897
02-15-08 22:06 nicolas cellier Note Added: 0011812
02-15-08 22:08 nicolas cellier Note Added: 0011813
02-15-08 22:09 nicolas cellier Note Edited: 0011813
07-04-08 01:50 matthewf Relationship added related to 0006887
08-09-08 08:25 ducasse Note Added: 0012475
11-20-08 20:35 KenCausey Status new => closed
11-20-08 20:35 KenCausey Note Added: 0012790
11-20-08 20:35 KenCausey Resolution open => fixed
11-20-08 20:35 KenCausey Fixed in Version  => 3.10


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
72 total queries executed.
47 unique queries executed.
Powered by Mantis Bugtracker