Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006532 [Squeak] ST80 minor always 06-07-07 06:53 07-03-09 00:24
Reporter caveman View Status public  
Assigned To
Priority normal Resolution won't fix Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.9
  Product Build
Summary 0006532: Found bug when using Spline example
Description After typing 'Spline example' and then clicking 'do it' I begin to set points on the workspace by left clicking. Once I am satisfied with the location of these points I click a diffrent mouse button to draw a path along these points and as soon as the path is drawn it disappears. Sometimes not only will the spline disappear but the expression as well leaving a blank workspace and sometimes I will only lay down a couple of dots before everything vanishes again. An interesting thing is that if I hold down the mouse button(either second or third doesn't matter) the spline will remain on the workspace but as soon as I release the button the spline vanishes. I am using an Intel Imac and a mighty mouse. I thought that maybe the mouse was dodgy so I downloaded a Windows version for my laptop which is running XP and uses an A-Link optical mouse but the problem is identical which seems to rule out any problem with operating system ports or mouse glitches.
Steps To Reproduce
Additional Information I would love to use Squeak and Croquet to write and share educational software.
Attached Files

- Relationships

- Notes
(0010780 - 496 - 496 - 496 - 496 - 496 - 496)
KenCausey
06-07-07 17:20

I think you are misunderstanding this example. Note first of all that this is quite old code and probably pre-dates Morphic. This example interacts with the mouse and display to allow you to specify a Spline, but it does not create a visible object (Morph) for it. It simply draws to the display in what would now, I think, be considered a somewhat hackish manner. The result is that any update to the display will erase part or all of the drawn spline. You may want to look at PolygonMorph.
 
(0010799 - 93 - 93 - 93 - 93 - 93 - 93)
wiz
06-11-07 23:45

Not a real bug. Spline is a somewhat obsolete class and problem was with example code anyway.
 
(0013143 - 41 - 41 - 41 - 41 - 41 - 41)
KenCausey
07-03-09 00:24

example code misunderstood, no bug to fix
 

- Issue History
Date Modified Username Field Change
06-07-07 06:53 caveman New Issue
06-07-07 06:53 caveman Status new => assigned
06-07-07 06:53 caveman Assigned To  => KenCausey
06-07-07 17:17 KenCausey Assigned To KenCausey =>
06-07-07 17:17 KenCausey Status assigned => new
06-07-07 17:17 KenCausey Category Any => ST80
06-07-07 17:20 KenCausey Note Added: 0010780
06-11-07 23:45 wiz Note Added: 0010799
06-11-07 23:45 wiz Status new => resolved
06-11-07 23:45 wiz Resolution open => won't fix
07-03-09 00:24 KenCausey Status resolved => closed
07-03-09 00:24 KenCausey Note Added: 0013143


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
49 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker