Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006583 [Squeak] Collections minor always 08-01-07 14:36 11-25-08 23:20
Reporter Damien Cassou View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.10
  Product Build 7130
Summary 0006583: PositionableStream>>back behavior is totally wrong
Description The current method #back is a misconception about what a stream is. A stream contains a pointer *between* elements with past and future elements. This method considers that the pointer is *on* an element.

Attached changeset:
- renames #back to #oldBack for backward compatibility
- implements #back
- adds 4 tests.

Please consider unit tests in the changeset which verifies #back and #oldBack behavior.

Steps To Reproduce
Additional Information
Attached Files  Collections-dc.89.mcz [^] (348,898 bytes) 08-02-07 09:51
 CollectionsTests-dc.72.mcz [^] (69,315 bytes) 08-02-07 09:51

- Relationships
duplicate of 0000368closed  PositionalStream>>back is not doing what it says 

- Notes
(0010953 - 47 - 47 - 173 - 173 - 173 - 173)
Damien Cassou
08-01-07 14:44

Same as: http://bugs.squeak.org/view.php?id=368 [^]
 
(0010956 - 148 - 172 - 172 - 172 - 172 - 172)
Damien Cassou
08-02-07 09:52

Please use the two mcz instead of FixingBackBehavior.1.cs.

They contain more changes:

- #peekBack has been fixed to follow the #back behavior.
 
(0012806 - 53 - 53 - 53 - 53 - 53 - 53)
KenCausey
11-25-08 23:20

Harvested as update 7146 and released in Squeak 3.10.
 

- Issue History
Date Modified Username Field Change
08-01-07 14:36 Damien Cassou New Issue
08-01-07 14:36 Damien Cassou File Added: FixingBackBehavior.1.cs
08-01-07 14:44 Damien Cassou Note Added: 0010953
08-02-07 09:51 Damien Cassou File Added: Collections-dc.89.mcz
08-02-07 09:51 Damien Cassou File Added: CollectionsTests-dc.72.mcz
08-02-07 09:52 Damien Cassou Note Added: 0010956
08-20-08 08:29 matthewf Relationship added duplicate of 0000368
11-23-08 15:40 Damien Cassou File Deleted: FixingBackBehavior.1.cs
11-25-08 23:20 KenCausey Status new => closed
11-25-08 23:20 KenCausey Note Added: 0012806
11-25-08 23:20 KenCausey Resolution open => fixed
11-25-08 23:20 KenCausey Fixed in Version  => 3.10


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
58 total queries executed.
38 unique queries executed.
Powered by Mantis Bugtracker