Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006590 [Squeak] Collections minor always 08-06-07 08:57 11-25-08 22:56
Reporter wbk View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.9
  Product Build
Summary 0006590: Fixes printing of Arrays with metaclasses.
Description Fixes printing with braces so that {Array class} printString = '{Array class}'.

Includes a test to cover this case. The problem was metaclasses didn't know that they were self evaluating.
Steps To Reproduce
Additional Information
Attached Files  PrintingArraysWithMetaclasses.1.cs [^] (352 bytes) 08-06-07 08:57

- Relationships

- Notes
(0010969 - 86 - 92 - 92 - 92 - 92 - 92)
edgardec
08-08-07 14:12

This now is 7141PrintingArraysWithMetaclasses.1.cs and was in updates for 3.10
Thanks
 
(0012802 - 55 - 55 - 55 - 55 - 55 - 55)
KenCausey
11-25-08 22:56

Harvested as update 7141 and released with Squeak 3.10.
 

- Issue History
Date Modified Username Field Change
08-06-07 08:57 wbk New Issue
08-06-07 08:57 wbk File Added: PrintingArraysWithMetaclasses.1.cs
08-08-07 14:12 edgardec Note Added: 0010969
08-11-07 04:40 wiz Status new => resolved
08-11-07 04:40 wiz Resolution open => fixed
08-11-07 04:40 wiz Fixed in Version  => 3.10
11-25-08 22:56 KenCausey Status resolved => closed
11-25-08 22:56 KenCausey Note Added: 0012802


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
44 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker