Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006702 [Squeak] System minor always 09-29-07 18:09 11-25-08 23:23
Reporter RalphJohnson View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version 3.10 Product Version 3.10
  Product Build
Summary 0006702: ChangeHooksTest has a bug
Description Running ChangehooksTest causes a notified to pop up for each test method. The notifier is caused by tearing down the test, because it tries to restore the old change set but fails. It tried to set the current change set with a message to ChangeOrganization, but it should have sent it to ChangeSet. I have a patch that fixes the test.
Steps To Reproduce
Additional Information
Attached Files  ChangeHooksTest-tearDown-M6702.st [^] (377 bytes) 09-29-07 18:14

- Relationships

- Notes
(0012807 - 55 - 55 - 55 - 55 - 55 - 55)
KenCausey
11-25-08 23:23

Harvested as update 7147 and released with Squeak 3.10.
 

- Issue History
Date Modified Username Field Change
09-29-07 18:09 RalphJohnson New Issue
09-29-07 18:14 RalphJohnson File Added: ChangeHooksTest-tearDown-M6702.st
11-25-08 23:23 KenCausey Status new => closed
11-25-08 23:23 KenCausey Note Added: 0012807
11-25-08 23:23 KenCausey Resolution open => fixed
11-25-08 23:23 KenCausey Fixed in Version  => 3.10


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
37 total queries executed.
30 unique queries executed.
Powered by Mantis Bugtracker