Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006724 [Squeak] Kernel minor always 10-11-07 21:25 07-04-08 01:58
Reporter nicolas cellier View Status public  
Assigned To
Priority normal Resolution duplicate Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.10
  Product Build
Summary 0006724: printStringBase: should be protected against wrong bases
Description
self should: [2 printStringBase: 1] raise: Error.
   "it does infinite loop"

"Found that in methodFinder with 2. 1. 3."


"Funnily, you can even print in non integer base"
(Float pi printStringBase: Float pi). '10.0'.

Steps To Reproduce
Additional Information
Attached Files

- Relationships
duplicate of 0007107closed nicolas cellier 1 printStringBase: 1 generates an infinite loop within Integer>>printStringBase: 

- Notes
(0011311 - 62 - 62 - 190 - 190 - 190 - 190)
nicolas cellier
10-13-07 21:36

And this is related to http://bugs.squeak.org/view.php?id=6710 [^]
 
(0012325 - 200 - 212 - 212 - 435 - 435 - 435)
nicolas cellier
07-03-08 19:32

Note that bug is reported again at 0007107

IMO the patch should be superseded by 0006887 which does not loop infinitely and which offers a much faster printString / printOn: / printStringBase: / etc...
 

- Issue History
Date Modified Username Field Change
10-11-07 21:25 nicolas cellier New Issue
10-13-07 21:36 nicolas cellier Note Added: 0011311
07-03-08 19:32 nicolas cellier Note Added: 0012325
07-04-08 01:47 matthewf Relationship added related to 0006710
07-04-08 01:47 matthewf Relationship added related to 0007107
07-04-08 01:47 matthewf Relationship added related to 0006887
07-04-08 01:54 matthewf Relationship replaced duplicate of 0007107
07-04-08 01:58 matthewf Relationship deleted related to 0006710
07-04-08 01:58 matthewf Relationship deleted related to 0006887
07-04-08 01:58 matthewf Status new => closed
07-04-08 01:58 matthewf Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
54 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker