Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006782 [Squeak] Collections major always 11-23-07 22:38 04-18-10 22:05
Reporter nicolas cellier View Status public  
Assigned To andreas
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version 3.10
  Product Build
Summary 0006782: 1.0 / (FloatArray with: 2.0) unexpected result
Description Try:
  1.0 / (FloatArray with: 2.0)
Answer is?
(FloatArray with: 2.0)

Hem...
Steps To Reproduce
Additional Information bug is in FloatArray>>adaptToNumber:andSend:
Attached Files  FloatArray-adapt-M6782-Test.1.cs [^] (725 bytes) 11-23-07 23:04
 FloatArray-adapt-M6782-Patch.1.cs [^] (958 bytes) 11-23-07 23:04

- Relationships

- Notes
(0011454 - 49 - 49 - 49 - 49 - 49 - 49)
nicolas cellier
11-23-07 22:39

Oops, Ken twice sorry, this one for Collection...
 
(0011455 - 274 - 365 - 365 - 365 - 365 - 365)
nicolas cellier
11-23-07 23:03

Obvious patch is:
    selector == #/ ifTrue:[^self reciprocal * rcvr].

However, this is bad, because of gradual underflow:
self reciprocal can give Infinity, while result is computable.

For example:
self should:
    (1.0e-39 / (FloatArray with: 1.0e-39)) first < 2
 
(0011559 - 173 - 239 - 239 - 239 - 239 - 239)
Keith_Hodges
12-17-07 16:39
edited on: 12-17-07 17:08

"fix begin"
Installer mantis bug: 6782 fix:'FloatArray-adapt-M6782-Patch.1.cs'.
"fix test"
Installer mantis bug: 6782 fix:'FloatArray-adapt-M6782-Test.1.cs'.
"fix end"

 
(0013264 - 64 - 64 - 224 - 224 - 224 - 224)
nicolas cellier
08-24-09 20:03

Fixed in http://source.squeak.org/trunk/Collections-nice.107.mcz [^]
 

- Issue History
Date Modified Username Field Change
11-23-07 22:38 nicolas cellier New Issue
11-23-07 22:38 nicolas cellier Status new => assigned
11-23-07 22:38 nicolas cellier Assigned To  => KenCausey
11-23-07 22:39 nicolas cellier Note Added: 0011454
11-23-07 23:03 nicolas cellier Note Added: 0011455
11-23-07 23:04 nicolas cellier File Added: FloatArray-adapt-M6782-Test.1.cs
11-23-07 23:04 nicolas cellier File Added: FloatArray-adapt-M6782-Patch.1.cs
11-24-07 22:33 KenCausey Assigned To KenCausey =>
11-24-07 22:33 KenCausey Status assigned => new
11-24-07 22:33 KenCausey Category Any => Collections
12-17-07 16:39 Keith_Hodges Note Added: 0011559
12-17-07 16:46 Keith_Hodges Note Edited: 0011559
12-17-07 17:08 Keith_Hodges Note Edited: 0011559
01-10-09 02:00 Keith_Hodges Status new => pending
01-10-09 02:27 Keith_Hodges Status pending => testing
01-10-09 03:39 Keith_Hodges Status testing => resolved
01-10-09 03:39 Keith_Hodges Fixed in Version  => 3.11
01-10-09 03:39 Keith_Hodges Resolution open => fixed
01-10-09 03:39 Keith_Hodges Assigned To  => Keith_Hodges
01-10-09 03:41 Keith_Hodges Status resolved => testing
08-24-09 20:03 nicolas cellier Note Added: 0013264
10-03-09 19:33 Keith_Hodges Status testing => assigned
10-03-09 19:33 Keith_Hodges Assigned To Keith_Hodges => andreas
10-03-09 20:16 nicolas cellier Status assigned => resolved
10-03-09 20:16 nicolas cellier Fixed in Version 3.11 => trunk
04-18-10 22:05 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
73 total queries executed.
40 unique queries executed.
Powered by Mantis Bugtracker