Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006788 [Squeak Packages] Polymorph minor always 11-28-07 13:25 01-07-08 12:38
Reporter mathk View Status public  
Assigned To GazzaGuru
Priority normal Resolution fixed Platform Mac OS
Status resolved   OS MacOSX
Projection none   OS Version 10.5
ETA none Product Build 7154
Summary 0006788: Bug with an Empty PluggableListMorph
Description When a PluggableListMorph have no item and you press a key you have a bug.

Steps To Reproduce Open OmniBrowser and go on the third or fourth empty panel.
If you hit a key you come up with a Debugger saying from Array "a primitive has failed".

This appear because of several reason:
  - The list contain no item
  - No item is selected so the algorithm is confused with the index.

The attached file fix the problem. (Since is UI stuff I don't have tests)
Additional Information
Attached Files  FixEmptyPluggableList.3.cs [^] (1,986 bytes) 11-28-07 13:38
 FixEmptyPluggableList.3 - M0006788.cs [^] (1,986 bytes) 11-28-07 13:38

- Relationships
related to 0006462closed  Squeak Jump-by-key in some lists broken 

- Notes
(0011484 - 48 - 48 - 48 - 48 - 48 - 48)
mathk
11-28-07 13:36

In fact this issue is only on a Squeak dev image
 
(0011485 - 80 - 98 - 98 - 98 - 98 - 98)
GazzaGuru
11-28-07 16:41

Was the error:
MessageNotUnderstood: UndefinedObject>>adaptToNumber:andSend:
?
 
(0011489 - 54 - 72 - 72 - 72 - 72 - 72)
mathk
11-28-07 19:42

Nop.
It was a Array class>>basicNew
'Primitive fail'
 
(0011493 - 165 - 165 - 165 - 165 - 165 - 165)
Damien Cassou
11-29-07 06:51

What you could try is to take a fresh 3.9 and load UI-Enhancements. Then, take a fresh 3.10 and load UI-Enhancements. Discuss here what happens exactly in each case.
 
(0011496 - 252 - 258 - 258 - 258 - 258 - 258)
GazzaGuru
11-29-07 17:20

Looks like I had integrated Daimen Pollet's fix too early, before the zero size fixup.. :-) This method is overridden in Widgets (UIEnhancements) to support disregarding key activity in disabled lists.
Updated in SqueakSource Pinesoft-Widgets-gvc.272.
 
(0011497 - 72 - 72 - 72 - 72 - 72 - 72)
GazzaGuru
11-29-07 17:21

If you'd like to try with the 272 version of Widgets to check the fix...
 
(0011637 - 73 - 73 - 73 - 73 - 73 - 73)
GazzaGuru
01-07-08 12:37

Given no feedback and it apparently working ok now I'm closing the issue.
 
(0011638 - 47 - 47 - 47 - 47 - 47 - 47)
GazzaGuru
01-07-08 12:38

Incorporated later fixes for list key handling.
 

- Issue History
Date Modified Username Field Change
11-28-07 13:25 mathk New Issue
11-28-07 13:36 mathk Note Added: 0011484
11-28-07 13:37 mathk Issue Monitored: mathk
11-28-07 13:38 mathk File Added: FixEmptyPluggableList.3.cs
11-28-07 13:38 mathk File Added: FixEmptyPluggableList.3 - M0006788.cs
11-28-07 14:08 Damien Cassou Project Squeak => Squeak Packages
11-28-07 14:09 Damien Cassou Project Squeak Packages => Squeak
11-28-07 14:12 Damien Cassou Project Squeak => Squeak Packages
11-28-07 14:13 Damien Cassou Category Morphic => UIEnhancements
11-28-07 16:38 GazzaGuru Status new => assigned
11-28-07 16:38 GazzaGuru Assigned To  => GazzaGuru
11-28-07 16:41 GazzaGuru Note Added: 0011485
11-28-07 19:42 mathk Note Added: 0011489
11-29-07 03:01 wiz Relationship added related to 0006462
11-29-07 06:51 Damien Cassou Note Added: 0011493
11-29-07 17:20 GazzaGuru Note Added: 0011496
11-29-07 17:21 GazzaGuru Note Added: 0011497
11-29-07 17:21 GazzaGuru Status assigned => feedback
01-07-08 12:37 GazzaGuru Note Added: 0011637
01-07-08 12:38 GazzaGuru Status feedback => resolved
01-07-08 12:38 GazzaGuru Resolution open => fixed
01-07-08 12:38 GazzaGuru Note Added: 0011638


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
82 total queries executed.
50 unique queries executed.
Powered by Mantis Bugtracker