Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006998 [Squeak] Collections minor always 04-02-08 21:43 04-18-10 22:05
Reporter nicolas cellier View Status public  
Assigned To andreas
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version 3.10
  Product Build
Summary 0006998: WideString>>at:put: does not return the put-object
Description Every other Collection does return the put-object.
a WideString would returns self...
It should not!

Thanks to Randal Schwartz for raising the question on #squeak channel.
Steps To Reproduce
Additional Information
Attached Files  WideString-atput-Test-M6998-nice.1.cs [^] (648 bytes) 04-02-08 21:57
 WideString-atput-Patch-M6998-nice.1.cs [^] (585 bytes) 04-02-08 21:57

- Relationships
related to 0001913closed  Make all implementors of #nextPut: to return the argument (instead of self) 

- Notes
(0011966 - 194 - 257 - 257 - 257 - 257 - 257)
nicolas cellier
04-02-08 22:31

Should also be the case of TwoLevelDictionary...
However, this one is more private, only used in:

TextDiffBuilder>>buildPatchSequence
    "@@ TODO: Das funktioniert noch nicht für n-m matches"
 
(0012014 - 281 - 293 - 293 - 419 - 419 - 419)
kwl
04-11-08 21:21

Nicolas,
I'm happy you found this. when I found issue 0001913 I checked what the VM returns (what will be returned if primitive does not fail). with #at:put: it is also possible to run into the same situation, since in many cases #at:put: can be handled by the VM alone.
Good find!
 
(0012861 - 183 - 237 - 237 - 237 - 237 - 237)
Keith_Hodges
12-17-08 04:43

"fix begin"
Installer mantis bug: 6998 fix: 'WideString-atput-Patch-M6998-nice.1.cs'.
"fix test"
Installer mantis bug: 6998 fix: 'WideString-atput-Test-M6998-nice.1.cs'.
"fix end"
 
(0013263 - 64 - 64 - 224 - 224 - 224 - 224)
nicolas cellier
08-24-09 20:02

Fixed in http://source.squeak.org/trunk/Collections-nice.106.mcz [^]
 

- Issue History
Date Modified Username Field Change
04-02-08 21:43 nicolas cellier New Issue
04-02-08 21:57 nicolas cellier File Added: WideString-atput-Test-M6998-nice.1.cs
04-02-08 21:57 nicolas cellier File Added: WideString-atput-Patch-M6998-nice.1.cs
04-02-08 22:31 nicolas cellier Note Added: 0011966
04-11-08 21:16 kwl Relationship added related to 0001913
04-11-08 21:21 kwl Note Added: 0012014
12-17-08 04:43 Keith_Hodges Note Added: 0012861
12-17-08 04:44 Keith_Hodges Status new => acknowledged
01-10-09 02:13 Keith_Hodges Status acknowledged => pending
01-10-09 02:27 Keith_Hodges Status pending => testing
01-10-09 03:40 Keith_Hodges Status testing => resolved
01-10-09 03:40 Keith_Hodges Fixed in Version  => 3.11
01-10-09 03:40 Keith_Hodges Resolution open => fixed
01-10-09 03:40 Keith_Hodges Assigned To  => Keith_Hodges
01-10-09 03:41 Keith_Hodges Status resolved => testing
08-24-09 20:02 nicolas cellier Note Added: 0013263
10-03-09 19:33 Keith_Hodges Status testing => assigned
10-03-09 19:33 Keith_Hodges Assigned To Keith_Hodges => andreas
10-03-09 20:04 nicolas cellier Status assigned => resolved
10-03-09 20:04 nicolas cellier Fixed in Version 3.11 => trunk
04-18-10 22:05 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
68 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker