Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007185 [Squeak] Compiler minor always 09-11-08 18:35 05-12-14 23:29
Reporter KenCausey View Status public  
Assigned To
Priority normal Resolution suspended Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.10.2
  Product Build
Summary 0007185: Deprecate MethodNode>>selector:arguments:precedence:temporaries:block:encoder:primitive:
Description This method has no users of of 3.10.2 and has been replaced with MethodNode>>selector:arguments:precedence:temporaries:block:encoder:primitive:properties:

See 0005936
Steps To Reproduce
Additional Information
Attached Files  MethodNode-deprecation-M7185.1.cs.gz [^] (365 bytes) 09-11-08 18:38

- Relationships
related to 0005936closed  [FIX] MethodNodeAPIFix-md (backward compatibility fix for MethodNode API) 

- Notes
(0012642 - 172 - 172 - 172 - 172 - 172 - 172)
KenCausey
09-11-08 18:39

If I remember correctly deprecation policy is to: 1. mark it as deprecated in a release, 2. leave it as marked for the next release, 3. remove it for the following release.
 
(0014502 - 417 - 465 - 465 - 465 - 465 - 465)
nicolas cellier
05-12-14 23:29

Since then, Eliot has redefined

DecompilerConstructor>>codeMethod: selector block: block tempVars: vars primitive: primitive class: class

to reuse this method... So it must not be deprecated anymore

Note that previously, above DecompilerConstructor did pass the original method properties, Eliot's version is passing an AdditionalMethodState new instead.
I can't judge which is right, I have to trust Eliot.
 

- Issue History
Date Modified Username Field Change
09-11-08 18:35 KenCausey New Issue
09-11-08 18:37 KenCausey Relationship added related to 0005936
09-11-08 18:38 KenCausey File Added: MethodNode-deprecation-M7185.1.cs.gz
09-11-08 18:39 KenCausey Note Added: 0012642
05-12-14 23:29 nicolas cellier Status new => closed
05-12-14 23:29 nicolas cellier Note Added: 0014502
05-12-14 23:29 nicolas cellier Resolution open => suspended


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker