Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007207 [Squeak Packages] OmniBrowser major always 10-06-08 16:02 10-07-08 05:25
Reporter dpollet View Status public  
Assigned To Damien Cassou
Priority normal Resolution duplicate Platform
Status closed   OS
Projection none   OS Version
ETA none Product Build
Summary 0007207: Primitive failed while jumping to method by keyboard
Description (In Pharo-dev updated to 10087, OmniBrowser-dr.419, OB-Enhancements-dr.220)
- open an OB Package Browser
- go to some class (e.g. Interval)
- move the mouse over the method column (don't click)
- press a letter key (e.g. "s", to jump to methods beginning with that letter)

primitive 71 fails in Array class >> basicNew:, from OBPluggableListMorph >> basicKeyPressed:

I guess this is related to the other bugs (can't find the numbers, sorry) with this method, probably the definitive fix wasn't harvested in Pharo?
Steps To Reproduce
Additional Information
Attached Files

- Relationships
duplicate of 0006462closed  Squeak Jump-by-key in some lists broken 

- Notes
(0012720 - 43 - 43 - 43 - 126 - 126 - 126)
Damien Cassou
10-06-08 16:19

Do you mean bug 0006462? Can you try the fix?
 
(0012721 - 137 - 137 - 137 - 137 - 137 - 137)
dpollet
10-06-08 16:30

I tried the fix and it works. The problem is caused by *Pinesoft-Widgets-override which was using older code (and is an override, duh :).
 
(0012723 - 34 - 34 - 34 - 34 - 34 - 34)
Damien Cassou
10-07-08 05:25

Please open a bug report on pharo.
 

- Issue History
Date Modified Username Field Change
10-06-08 16:02 dpollet New Issue
10-06-08 16:02 dpollet Status new => assigned
10-06-08 16:02 dpollet Assigned To  => Damien Cassou
10-06-08 16:19 Damien Cassou Note Added: 0012720
10-06-08 16:30 dpollet Note Added: 0012721
10-07-08 05:24 Damien Cassou Relationship added duplicate of 0006462
10-07-08 05:25 Damien Cassou Status assigned => closed
10-07-08 05:25 Damien Cassou Note Added: 0012723
10-07-08 05:25 Damien Cassou Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
49 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker