Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007371 [Squeak] VM crash always 07-17-09 14:35 08-13-09 17:35
Reporter faried View Status public  
Assigned To lewis
Priority normal Resolution duplicate Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version Product Version 3.10.2
  Product Build
Summary 0007371: uuid plugin issue, maybe: trying to select bigDisplay in the preferences browser generates a segfault
Description The output is:

Segmentation fault

23442636 UUID>initialize
23442520 Behavior>new:
23442428 >new
23442336 >setTimeStamp
23442152 >updateInstances
23439964 >setMenuFontTo:
23041932 [] in >smallLandBigFonts
23041840 SequenceableCollection>do:
23041748 >smallLandBigFonts
23041656 >smallLandFonts
23041564 >displaySizeChanged
23041380 Preference>notifyInformeeOfChange
23041288 Preference>togglePreferenceValue
23041196 [] in ThreePhaseButtonMorph>doButtonAction:
23041068 BlockContext>ensure:
23040976 Cursor>showWhile:
23040884 ThreePhaseButtonMorph>doButtonAction:
23040464 ThreePhaseButtonMorph>mouseUp:
23040372 UpdatingThreePhaseButtonMorph>mouseUp:
23040280 Morph>handleMouseUp:
23040188 MouseButtonEvent>sentTo:
23040096 Morph>handleEvent:
23040004 Morph>handleFocusEvent:
23040556 [] in HandMorph>sendFocusEvent:to:clear:
23040648 [] in PasteUpMorph>becomeActiveDuring:
23039912 BlockContext>on:do:
23039820 PasteUpMorph>becomeActiveDuring:
23039636 HandMorph>sendFocusEvent:to:clear:
23039544 HandMorph>sendEvent:focus:clear:
23039452 HandMorph>sendMouseEvent:
23039308 HandMorph>handleEvent:
23038952 HandMorph>processEvents
23039044 [] in WorldState>doOneCycleNowFor:
23038860 SequenceableCollection>do:
23038768 WorldState>handsDo:
23038676 WorldState>doOneCycleNowFor:
23038584 WorldState>doOneCycleFor:
23038492 PasteUpMorph>doOneCycle
14563612 [] in >spawnNewProcess
14563796 [] in BlockContext>newProcess
Aborted

Under gdb:

(gdb) Starting program: /usr/local/lib/squeak/3.10-5/squeak -vm-display-X11 -xshm -xasync

Program received signal SIGSEGV, Segmentation fault.
0x00007fd49643a84a in ?? () from /lib/libuuid.so.1
(gdb) bt
#0 0x00007fd49643a84a in ?? () from /lib/libuuid.so.1
#1 0x00007fd49643b5c9 in uuid_generate () from /lib/libuuid.so.1
0000002 0x00007fd4554309b0 in MakeUUID (location=0x7fd456f21418 "")
    at /home/fn/repos/squeak-svn/platforms/unix/plugins/UUIDPlugin/sqUnixUUID.c:17
0000003 0x000000000041e397 in primitiveExternalCall () at gnu-interp.c:3933
0000004 0x000000000042abb7 in interpret () at gnu-interp.c:3933
0000005 0x00000000004128e5 in main (argc=<value optimized out>, argv=0x7fffa18b7cb8, envp=<value optimized out>)
    at /home/fn/repos/squeak-svn/platforms/unix/vm/sqUnixMain.c:1411
(gdb) up
#1 0x00007fd49643b5c9 in uuid_generate () from /lib/libuuid.so.1
(gdb) up
0000002 0x00007fd4554309b0 in MakeUUID (location=0x7fd456f21418 "")
    at /home/fn/repos/squeak-svn/platforms/unix/plugins/UUIDPlugin/sqUnixUUID.c:17
17 uuid_generate(uuid);
(gdb) print uuid
$1 = "H�\000\000\000\000\000C\tCU�177\000"
(gdb) up
0000003 0x000000000041e397 in primitiveExternalCall () at gnu-interp.c:3933
3933 ((void (*)(void))aFunctionPointer)();

This happens both with and without the -xshm -xasync options.

I rebuilt it with libuuid1-dbg instead of uuid-dev, and got this instead:

Program received signal SIGSEGV, Segmentation fault.
0x00007ff9c861084a in get_random_fd () at /build/buildd/e2fsprogs-1.41.4/lib/uuid/gen_uuid.c:153
153 /build/buildd/e2fsprogs-1.41.4/lib/uuid/gen_uuid.c: No such file or directory.
        in /build/buildd/e2fsprogs-1.41.4/lib/uuid/gen_uuid.c
(gdb) bt
#0 0x00007ff9c861084a in get_random_fd () at /build/buildd/e2fsprogs-1.41.4/lib/uuid/gen_uuid.c:153
#1 0x00007ff9c86115c9 in uuid_generate (out=0x7ff9cba6adb0 "\002") at /build/buildd/e2fsprogs-1.41.4/lib/uuid/gen_uuid.c:619
0000002 0x00007ff9876069b0 in MakeUUID (location=0x7ff989139788 "")
    at /home/fn/repos/squeak-svn/platforms/unix/plugins/UUIDPlugin/sqUnixUUID.c:17
0000003 0x000000000041e397 in primitiveExternalCall () at gnu-interp.c:3933
0000004 0x000000000042abb7 in interpret () at gnu-interp.c:3933
0000005 0x00000000004128e5 in main (argc=<value optimized out>, argv=0x7fffd3a8de88, envp=<value optimized out>)
    at /home/fn/repos/squeak-svn/platforms/unix/vm/sqUnixMain.c:1411

Steps To Reproduce
Additional Information I am using the vm out of svn (trunk, rev 1997). I'm running it on a 64bit Ubuntu 9.04 system. The vm was compiled with

../platforms/unix/config/configure --without-quartz

`file squeak` says

/usr/local/lib/squeak/3.10-5/squeak: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, not stripped

I'm going to try building it with gcc -m32 on Monday.
Attached Files

- Relationships
duplicate of 0007358acknowledged lewis UUID>>initialize may crash VM for some images 

- Notes
(0013199 - 139 - 151 - 431 - 431 - 431 - 431)
faried
07-17-09 14:41

Oops. I just read http://bugs.squeak.org/view.php?id=7358 [^] and http://code.google.com/p/pharo/issues/detail?id=855 [^]

It's a known problem.
 
(0013226 - 28 - 28 - 28 - 136 - 136 - 136)
KenCausey
08-13-09 17:35

Closed as duplicate of 0007358
 

- Issue History
Date Modified Username Field Change
07-17-09 14:35 faried New Issue
07-17-09 14:35 faried Status new => assigned
07-17-09 14:35 faried Assigned To  => lewis
07-17-09 14:41 faried Note Added: 0013199
07-17-09 16:54 lewis Relationship added duplicate of 0007358
08-13-09 17:35 KenCausey Status assigned => closed
08-13-09 17:35 KenCausey Note Added: 0013226
08-13-09 17:35 KenCausey Resolution open => duplicate


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
52 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker