Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007404 [Squeak] Collections feature N/A 10-05-09 07:18 04-18-10 22:04
Reporter nicolas cellier View Status public  
Assigned To nicolas cellier
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version trunk
  Product Build
Summary 0007404: Use postCopy paradigm in collections
Description There are several advantages:
1) unify a bit the code
2) correct bugs 0007402 and 0007403 (and maybe a few others...)
3) solve 0006535 without adding a new basicShallowCopy message
Steps To Reproduce
Additional Information
Attached Files  CollectionPostCopyParadigm_nice.1.cs [^] (6,468 bytes) 10-05-09 07:21
 CollectionPostCopyBlockCleanUp-nice.1.cs [^] (1,276 bytes) 10-05-09 08:11

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0007402closed nicolas cellier The copy of a LInkedList is not a LinkedList 
related to 0007403closed nicolas cellier The copy of a ShortRunArray is not a ShortRunArray 
related to 0006535closed andreas keyBlock and sortBlock are lost when creating a collection of the same species. 

- Notes
(0013341 - 184 - 250 - 250 - 250 - 250 - 250)
nicolas cellier
10-05-09 07:22
edited on: 10-05-09 08:58

"fix begin"
Installer mantis bug: 7404 fix:'CollectionPostCopyParadigm_nice.1.cs'.
Installer mantis bug: 7404 fix:'CollectionPostCopyBlockCleanUp-nice.1.cs'.
"fix test"
"fix end"

 
(0013344 - 64 - 64 - 224 - 224 - 224 - 224)
nicolas cellier
10-05-09 08:57

Fixed in http://source.squeak.org/trunk/Collections-nice.157.mcz [^]
 
(0013345 - 73 - 73 - 73 - 73 - 73 - 73)
nicolas cellier
10-05-09 08:59

I also cleaned up postCopyBlocks because fixTemps is not required anymore
 

- Issue History
Date Modified Username Field Change
10-05-09 07:18 nicolas cellier New Issue
10-05-09 07:21 nicolas cellier File Added: CollectionPostCopyParadigm_nice.1.cs
10-05-09 07:22 nicolas cellier Note Added: 0013341
10-05-09 08:11 nicolas cellier File Added: CollectionPostCopyBlockCleanUp-nice.1.cs
10-05-09 08:57 nicolas cellier Relationship added related to 0006535
10-05-09 08:57 nicolas cellier Status new => resolved
10-05-09 08:57 nicolas cellier Fixed in Version  => trunk
10-05-09 08:57 nicolas cellier Resolution open => fixed
10-05-09 08:57 nicolas cellier Assigned To  => nicolas cellier
10-05-09 08:57 nicolas cellier Note Added: 0013344
10-05-09 08:58 nicolas cellier Note Edited: 0013341
10-05-09 08:59 nicolas cellier Note Added: 0013345
10-05-09 12:29 nicolas cellier Relationship added related to 0007402
10-05-09 12:29 nicolas cellier Relationship added related to 0007403
04-18-10 22:04 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
65 total queries executed.
41 unique queries executed.
Powered by Mantis Bugtracker