Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007414 [Squeak] Compiler minor always 11-16-09 16:33 04-18-10 21:57
Reporter cwp View Status public  
Assigned To laza
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version trunk
  Product Build
Summary 0007414: A copied block containing a return raises BlockCannotReturn
Description If a block containing a return is copied, it will raise BlockCannotReturn when it's evaluated, even if the home context is still on the stack.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0013540 - 92 - 92 - 92 - 92 - 92 - 92)
laza
03-10-10 08:32

I can't reproduce this in trunk 9652. Has this been fixed or do you have a testcase at hand?
 
(0013548 - 155 - 167 - 167 - 167 - 167 - 167)
leves
03-11-10 11:36

I think it was fixed in Kernel-nice.300 by removing BlockClosure >> #postCopy.
The commit message is: Fix evaluation of Block copy in case of local return
 
(0013549 - 44 - 44 - 44 - 44 - 44 - 44)
laza
03-11-10 14:49

True, i also found the discussion about this
 

- Issue History
Date Modified Username Field Change
11-16-09 16:33 cwp New Issue
03-10-10 08:32 laza Note Added: 0013540
03-10-10 08:32 laza Status new => feedback
03-11-10 11:36 leves Note Added: 0013548
03-11-10 14:49 laza Status feedback => resolved
03-11-10 14:49 laza Fixed in Version  => trunk
03-11-10 14:49 laza Resolution open => fixed
03-11-10 14:49 laza Assigned To  => laza
03-11-10 14:49 laza Note Added: 0013549
04-18-10 21:57 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker