Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007445 [Squeak] Files block sometimes 01-13-10 18:17 04-18-10 21:57
Reporter wiz View Status public  
Assigned To andreas
Priority immediate Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version trunk
  Product Build
Summary 0007445: In 8864 Saveing a project can still hang (4th bug and counting)
Description As I was recovering from my last crash I started to save a project with a name that I had already used.

I got the "you've already used that name and this project has never been saved before, save anyway?"

I proceeded to save.

The process hung.

Alt-. to user interupt.
Then selected jump to previous (parent) project.

In the parent project I got a debug box. (debug log attached)

In the depths of
ar 1/3/2010 19:01 MorphicProject exportSegmentWithChangeSet:fileName:directory: {file in/out}

ar 10/4/2009 22:22 FileDirectory = {comparing}

is called comparing the directory path to a pasteup morph.

The pasteup morph complains about being sent #pathname.







Steps To Reproduce
Additional Information It seems to me = has the duty to take on all comers. So
ar 10/4/2009 22:22 FileDirectory = {comparing}
is the culprit.

Yours in curiosity and service, --Jerome Peace


Attached Files  SqueakDebug10jan13a.log [^] (4,161 bytes) 01-13-10 18:17
 MorphicProject-exportSegmentWithChangeSetfileNamedirectory.st [^] (4,538 bytes) 01-13-10 18:30

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

duplicate of 0007456closed leves In sq 8864 evaluating 'FileDirectory default = nil' causes an MNU #pathName 
related to 0007440closed wiz In sq 8859 Saving a project hangs (even after avoiding the first two problems) 

- Notes
(0013471 - 43 - 43 - 43 - 43 - 43 - 43)
wiz
01-13-10 18:22

Reminder sent to: andreas

Another one of yours I believe. Cheers -Jer
 
(0013472 - 55 - 55 - 55 - 55 - 55 - 55)
andreas
01-13-10 18:30

Can you try this patch and see if it fixes the problem?
 
(0013481 - 545 - 677 - 677 - 677 - 677 - 677)
wiz
01-16-10 06:49

I've downloaded the patch. Now I've got to figure a way to try it.

However, just looking at it I see it doesn't touch.

ar 10/4/2009 22:22 FileDirectory = {comparing}

Which needs to allow filedirctories to be compared to objects in general.

Right now the simple test



FileDirectory instance = PasteUpMorph instance will fail with and error.

Possibly

FileDirectory instance = nil will fail with an error.

You need to write tests around this; watch them fail; and make them pass.

Time to up your game.

Cheers --Jer
 
(0013482 - 880 - 1009 - 1009 - 1138 - 1138 - 1138)
wiz
01-16-10 08:19

My attempts to recreate the problem in sq #8875 fail.

So I have not base case to compare the patch to.

I tried saving a fresh project with code into a project name that had already been used.
After being cautioned and proceeding
Then being asked if I wanted to save code and answering yes.
The save was completed.

Those were the conditions that hung the last time.
And I checked versions for the patch method in sq 8875 it is
ar 1/3/2010 19:01 MorphicProject exportSegmentWithChangeSet:fileName:directory: {file in/out}

The isScriptTile fallback method is Object>.isScriptTile now rather than morph.
So that is consistent with what was needed for mantis 0007440.

I did not try to read the project back in.

Conclusion so far--
I don't know of a good way to test the patch since I can't recreate the problem even when the patch is not there.

Cheers --Jer
 
(0013535 - 27 - 27 - 27 - 27 - 27 - 27)
laza
03-09-10 19:54

Patch is in the Trunk image
 

- Issue History
Date Modified Username Field Change
01-13-10 18:17 wiz New Issue
01-13-10 18:17 wiz Status new => assigned
01-13-10 18:17 wiz Assigned To  => KenCausey
01-13-10 18:17 wiz File Added: SqueakDebug10jan13a.log
01-13-10 18:18 wiz Assigned To KenCausey =>
01-13-10 18:18 wiz Category Any => Files
01-13-10 18:20 wiz Relationship added related to 0007440
01-13-10 18:22 wiz Issue Monitored: andreas
01-13-10 18:22 wiz Note Added: 0013471
01-13-10 18:30 andreas File Added: MorphicProject-exportSegmentWithChangeSetfileNamedirectory.st
01-13-10 18:30 andreas Note Added: 0013472
01-13-10 18:48 KenCausey Assigned To  => andreas
01-16-10 06:49 wiz Note Added: 0013481
01-16-10 08:19 wiz Note Added: 0013482
01-17-10 05:56 wiz Relationship added duplicate of 0007456
03-09-10 19:54 laza Status assigned => resolved
03-09-10 19:54 laza Fixed in Version  => trunk
03-09-10 19:54 laza Resolution open => fixed
03-09-10 19:54 laza Note Added: 0013535
04-18-10 21:57 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
76 total queries executed.
48 unique queries executed.
Powered by Mantis Bugtracker