Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007457 [Squeak] Tools major always 01-20-10 04:02 04-18-10 21:59
Reporter wiz View Status public  
Assigned To andreas
Priority immediate Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version trunk
  Product Build
Summary 0007457: in sq 8883 browser menu item 'copy up or down' ignores contents of codeholder
Description For this one open a browser
select a method (I used StarMorph>addStarHandles)
get a yellow menu for it (middle click on ubuntu)>more>copy up or down)
select a target class ( I used PolygonMorph)


notice you get a category browser for the category in the new class.
but the contents have not been copied.
Steps To Reproduce
Additional Information The culprit seems to be:
'ar 8/8/2009 17:05 Browser openMessageCatEditString: {initialize-release}'

which replaces a totally different:
'sd 11/20/2005 21:26 Browser openMessageCatEditString: {initialize-release}'
 

The new method totally ignores its argument aString (the code holder contents). Something is seriously wrong.


I've put the priority an urgentcy high because this breaks a useful tool that wasn't broken before.

Yours in curiosity and service, --Jerome Peace
Attached Files

- Relationships

- Notes
(0013488 - 110 - 156 - 156 - 156 - 156 - 156)
wiz
01-20-10 04:03

Reminder sent to: andreas

Hi andreas,

Another one.

Maybe it time to start wondering about getting "test infected".

Cheers --Jer
 
(0013489 - 53 - 53 - 53 - 53 - 53 - 53)
wiz
01-20-10 04:36

On second thought this is not a blocking issue. --Jer
 
(0013490 - 15 - 15 - 15 - 15 - 15 - 15)
andreas
01-20-10 04:45

Fixed in trunk.
 

- Issue History
Date Modified Username Field Change
01-20-10 04:02 wiz New Issue
01-20-10 04:03 wiz Issue Monitored: andreas
01-20-10 04:03 wiz Note Added: 0013488
01-20-10 04:36 wiz Note Added: 0013489
01-20-10 04:36 wiz Severity block => major
01-20-10 04:45 andreas Status new => resolved
01-20-10 04:45 andreas Fixed in Version  => trunk
01-20-10 04:45 andreas Resolution open => fixed
01-20-10 04:45 andreas Assigned To  => andreas
01-20-10 04:45 andreas Note Added: 0013490
04-18-10 21:59 andreas Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker