Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007466 [Squeak] Morphic major always 02-27-10 05:04 03-11-10 22:51
Reporter matthewf View Status public  
Assigned To
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version trunk
  Product Build
Summary 0007466: "End", "Page Up", and "Page Down" keys broken
Description When I'm using a trunk image and press the End key, Squeak seems to think I've pressed the Page Down key. This is a problem for 3 of my keys:

I press: end
I get: page down
keycode: 4

I press: page up
I get: an unprintable character
keycode: 11

I press: page down
I get: page up
keycode: 12

I got the keycode by running Sensor kbdTest.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0013534 - 191 - 191 - 191 - 191 - 191 - 191)
laza
03-09-10 19:37

I get the same keycodes (on Windows), but the behavior is as expected. On which platform does this happen? I can't reproduce this neither on Linux nor on Windows with the latest Trunk Image.
 
(0013552 - 65 - 65 - 65 - 65 - 65 - 65)
matthewf
03-11-10 22:51

problem solved by upgrading to the latest unix VM on squeakvm.org
 

- Issue History
Date Modified Username Field Change
02-27-10 05:04 matthewf New Issue
02-27-10 05:11 matthewf Description Updated
03-09-10 19:37 laza Note Added: 0013534
03-09-10 19:37 laza Status new => feedback
03-11-10 22:51 matthewf Status feedback => closed
03-11-10 22:51 matthewf Note Added: 0013552
03-11-10 22:51 matthewf Resolution open => fixed
03-11-10 22:51 matthewf Fixed in Version  => trunk


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
42 total queries executed.
32 unique queries executed.
Powered by Mantis Bugtracker