Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007510 [Squeak] Files major always 04-22-10 21:00 02-06-11 23:48
Reporter wiz View Status public  
Assigned To leves
Priority high Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version 4.1
  Product Build
Summary 0007510: In sq 9956 draging and dropping a project file causes an MNU.
Description For this one:

On Ubuntu/Linux (I doubt the platform matters)

In a fresh squeak 4.1
create and save a project.

In another fresh squeak
Drag the file from a folder onto the squeak image.

From the pop up menu select load as project.

Note debugger comes up:

MessageNotUnderstood: MultiByteFileStream>>dirAndFileName


Squeak4.1
latest update: #9956

Current vm2022 final released with 4.1
Steps To Reproduce
Additional Information #dirAndFileName is implemented only in FileList

Reading the project in with file list worked okay.

Ideally I would like dropping a project onto the image to simply open the project assuming that is possible.

I realize that projects saved before a certain version won't work in 4.1 However when dropped there should be a simple way of determining if that is the case. E.G. the project might have a project version header that identifies it as being 4.1 or later. Then you could just go ahead and load it.

I wish to return to being a lazy programmer.

Yours in curiosity and service, --Jerome Peace
Attached Files

- Relationships

- Notes
(0013728 - 162 - 186 - 186 - 320 - 320 - 320)
wiz
04-23-10 05:08

This seems to be similar to the problem mentioned in 0007499.

Dragging and droping pictures still works. So this is not a regression of that fix.

Cheers, -Jer
 
(0013943 - 291 - 297 - 297 - 297 - 297 - 297)
leves
11-23-10 09:56

The cause of the issue is that the same service is used for loading from FileList and for drop handling. Implementing StandardFileStream >> #dirAndFile is a solution for this issue, but it will postpone the cleanup and refactoring of ProjectViewMorph, ProjectLoading, FileList and FileList2.
 
(0013944 - 22 - 22 - 22 - 22 - 22 - 22)
leves
11-23-10 10:30

Fixed in Tools-ul.279.
 

- Issue History
Date Modified Username Field Change
04-22-10 21:00 wiz New Issue
04-23-10 05:08 wiz Note Added: 0013728
11-23-10 09:56 leves Note Added: 0013943
11-23-10 09:56 leves Status new => confirmed
11-23-10 10:30 leves Status confirmed => resolved
11-23-10 10:30 leves Fixed in Version  => trunk
11-23-10 10:30 leves Resolution open => fixed
11-23-10 10:30 leves Assigned To  => leves
11-23-10 10:30 leves Note Added: 0013944
02-06-11 23:48 leves Status resolved => closed


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
48 total queries executed.
37 unique queries executed.
Powered by Mantis Bugtracker