Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007588 [Squeak] Compiler minor always 12-19-10 22:26 01-05-13 21:02
Reporter FrankShearar View Status public  
Assigned To FrankShearar
Priority normal Resolution fixed Platform
Status closed   OS
Projection none   OS Version
ETA none Fixed in Version trunk Product Version 4.3
  Product Build
Summary 0007588: Decompiler>>interpretNextInstructionFor: bitrot
Description If you change the first statement in the above-mentioned method to

  false ifTrue: [^ super interpretNextInstructionFor: client].

you will print out debug information. Or you would if you didn't get an exception printing out the bytecode. "code copyFrom: 4 to: code size" fails because it tries to make a String of size -2. That's because code at this point is something like '70' if you're currently interpreting bytecode 112.

Changing the offending line to "nextPutAll: '<', code, '>' fixes things.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0013997 - 88 - 88 - 240 - 240 - 240 - 240)
FrankShearar
12-19-10 22:29

Potential fix uploaded to the Inbox: http://source.squeak.org/inbox/Compiler-fbs.183.mcz [^]
 
(0014051 - 69 - 69 - 221 - 221 - 221 - 221)
nicolas cellier
02-16-11 00:18

In http://source.squeak.org/trunk/Compiler-fbs.183.mcz [^] then merged...
 

- Issue History
Date Modified Username Field Change
12-19-10 22:26 FrankShearar New Issue
12-19-10 22:26 FrankShearar Status new => assigned
12-19-10 22:26 FrankShearar Assigned To  => FrankShearar
12-19-10 22:29 FrankShearar Note Added: 0013997
01-16-11 21:14 FrankShearar Status assigned => pending
02-16-11 00:18 nicolas cellier Status pending => resolved
02-16-11 00:18 nicolas cellier Fixed in Version  => trunk
02-16-11 00:18 nicolas cellier Resolution open => fixed
02-16-11 00:18 nicolas cellier Note Added: 0014051
01-05-13 21:02 nicolas cellier Status resolved => closed
01-05-13 21:02 nicolas cellier version  => 4.3


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
45 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker