Mantis Bugtracker
  

Viewing Issue Advanced Details Jump to Notes ] View Simple ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0007626 [Squeak] Tools minor always 04-26-11 21:14 05-02-11 17:10
Reporter FrankShearar View Status public  
Assigned To leves
Priority normal Resolution fixed Platform
Status resolved   OS
Projection none   OS Version
ETA none Fixed in Version Product Version trunk
  Product Build
Summary 0007626: Alphabetising message categories in a Browser doesn't preserve currently selected message category
Description As above.
Steps To Reproduce
Additional Information
Attached Files

- Relationships

- Notes
(0014084 - 254 - 270 - 270 - 270 - 270 - 270)
leves
05-01-11 01:09

The same is true for system categories. Removing the line "self selectSystemCategory: nil." from Browser >> #alphabetizeSystemCategories fixes that, but I wonder if it has any negative side effects. Fixing the message categories seems to be a bit harder.
 
(0014085 - 343 - 361 - 701 - 701 - 701 - 701)
FrankShearar
05-01-11 08:11

* http://source.squeakfoundation.org/inbox/Tools-fbs.346.mcz [^]
* http://source.squeakfoundation.org/inbox/ToolsTests-fbs.41.mcz [^]

I don't know if there are additional repercussions, but if we simply remember where we were, and restore afterwards, things should Just Work (because we already handle the case where a method/category disappears).
 
(0014087 - 27 - 27 - 27 - 27 - 27 - 27)
FrankShearar
05-02-11 17:10

leves added these to Trunk.
 

- Issue History
Date Modified Username Field Change
04-26-11 21:14 FrankShearar New Issue
04-26-11 21:14 FrankShearar Status new => assigned
04-26-11 21:14 FrankShearar Assigned To  => FrankShearar
05-01-11 01:09 leves Note Added: 0014084
05-01-11 08:11 FrankShearar Note Added: 0014085
05-01-11 08:11 FrankShearar Assigned To FrankShearar => leves
05-01-11 08:11 FrankShearar Status assigned => feedback
05-02-11 17:10 FrankShearar Status feedback => resolved
05-02-11 17:10 FrankShearar Resolution open => fixed
05-02-11 17:10 FrankShearar Note Added: 0014087


Mantis 1.0.8[^]
Copyright © 2000 - 2007 Mantis Group
46 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker